Disable acceleration for laser mode

This is my firsts experiences with laser engraving.
I have noticed that the "printer" still accelerating the motors even in laser mode, the burn it stronger in the line start and as it accelerates the burn is lower again then stronger at its end, and I believe it is because of the acceleration.
1. There a way to disable the acceleration?
2. There a way to disable the acceleration just in the laser mode?
3. There a way to disable the acceleration just in laser on moves but not the travel moves?

Thank you very much.


  • a simple solution would be to use :
     M201 - Set max acceleration in units/s^2 for print moves (M201 X1000 Y1000)
    (M202 - Set max acceleration in units/s^2 for travel moves (M202 X1000 Y1000))

    so it´s easy to add f.e.  M201 X10000 Y10000 (10000 is a high value that comes close to no acceleration)
    at beginning of your GCode and go back to your Standard value (f.e. 200) at the end of your GCode
    with M201 X200 Y200

  • Acceleration is always active. Only solution is to set xy jerk to 2*print speed. Acceleration only happens when you are above that speed. But that is limited to what your printer can handle or you will loose steps.
  • Repetier, maybe do you have a better idea for this?
    There is a way to set the jerk by g-code? It is a permanent setting?
  • - M207 X<XY jerk> Z<Z Jerk> E<ExtruderJerk> - Changes current jerk values, but
    do not store them in eeprom.

    Might still end in eeprom if you later store eeprom like when all heaters get disabled, so better always set back to start values after usage.
Sign In or Register to comment.