Serious problems with FW compiling by Arduino IDE

Hello forum,

i need some help please.
Yesterday want to configure new FW with configuration tool on Repetier site, than download it and open with arduino IDE.
Can't send it to the mega because got a lot of errors during compiling, try older versions of IDE and same problem.
Than i try a old downloaded and configured FW from 2016 and try compiling it with old IDE and got same problems.
2 years ago was no problem during compiling and than upload to mega.
Here the error list:
Arduino: 1.8.5 (Windows 7), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

sketch\Eeprom.cpp: In static member function 'static void EEPROM::restoreEEPROMSettingsFromConfiguration()':

Eeprom.cpp:105: error: expected primary-expression before ';' token

heatedBedController.pidPGain = HEATED_BED_PID_PGAIN_OR_DEAD_TIME;

^

Eeprom.cpp:106: error: expected primary-expression before ';' token

heatedBedController.pidIGain = HEATED_BED_PID_IGAIN;

^

Eeprom.cpp:131: error: expected primary-expression before ';' token

e->stepsPerMM = EXT0_STEPS_PER_MM;

^

Eeprom.cpp:139: error: expected primary-expression before ';' token

e->tempControl.pidPGain = EXT0_PID_PGAIN_OR_DEAD_TIME;

^

Eeprom.cpp:140: error: expected primary-expression before ';' token

e->tempControl.pidIGain = EXT0_PID_I;

^

Eeprom.cpp:141: error: expected primary-expression before ';' token

e->tempControl.pidDGain = EXT0_PID_D;

^

sketch\Eeprom.cpp: In static member function 'static void EEPROM::initalizeUncached()':

Eeprom.cpp:467: error: expected primary-expression before ')' token

HAL::eprSetFloat(EPR_Z_PROBE_HEIGHT, Z_PROBE_HEIGHT);

^

sketch\Eeprom.cpp: In static member function 'static void EEPROM::readDataFromEEPROM(bool)':

Eeprom.cpp:663: error: expected primary-expression before ')' token

HAL::eprSetFloat(EPR_Z_PROBE_HEIGHT, Z_PROBE_HEIGHT);

^

exit status 1
expected primary-expression before ';' token


Please help
Regards
Hermann

Comments

  • Eeprom.cpp:105: error: expected primary-expression before ';' token

    heatedBedController.pidPGain = HEATED_BED_PID_PGAIN_OR_DEAD_TIME;

    HEATED_BED_PID_PGAIN_OR_DEAD_TIME is a macro defined in configuration.h. If it is not in the config file compiler gets there nothing making sense causing the error. So my guess is that your configuration.h doe snot define these values. Maybe because it is an older config which does not define them, also at least EXT0_PID_I is very old.

    Also current releases require a newer arduino ide, but I see you have 1.8.5 which is new enough for the current releases. But I think they have problems with very old firmwares as arduino has changed a bit the handling of the files.
  • edited September 22
    Thank you very much for fast response.
    I tried compiling with the latest portable IDE because i had problems installing newer IDE (but this not affect the compiler)
    Always a lot of errors.
    Some of this errors are not defined PID values from extruder or heat bed, but this make no sense because i choose and define it in the configuration tool...
    What can i do ?

  • edited September 22
    the same for EXT_STEPS_PER_MM
    error because it seems there are no value set but im sure i did it in the config tool.
    So i tried to set the value in the config.h and the error disappear.
    The problem is that some values are not in the config.h
    The question now is why this values disappear when compiling but was setting in the repetier configuration tool ?
    and what eeprom should i set? eeprom1 or eeprom2

  • Are these values with a comma? It matters if you use . or , as they are marked as number. Guess if they are in wrong format they are written as not existing values. Might also depend on browser. In chrome I need , as I'm using german settings but . works as well. Other browsers might behave different here.
  • Thank you for the input.
    Probably the prob is the browser because since 3 months i use the firefox and before i had the chrome browser.
    I try to change it and report later
  • edited September 24
    RESOLVED !!!

    The problem was the browser, with Firefox got a lot of compiling errors, with Chrome no problems :)

    Thank you for helping
Sign In or Register to comment.