after update server host + raspberry server no more work

again in deep problems
all was working fine with previous version
after re organization of my workshop i saw new version of host and raspberry server are issued, so i install them and now when i re enter parameters for my printer , enter new api key ,and try a wifi connect ,it dont work,

now ,on server side, looking global parameters/wlan ,i get "this installation do not support wifi "
what i done of wrong ?



  • What pi version and image version are you using? V18 is using the latest buster release from raspbian so might be a problem with that not detecting the wlan adaper. I have tested Pi 3 and Pi 4 and Pi Zero W to work before releasing.
  • hi 
    i use Repetier server image 9_92_2_v18 on raspberry pi 3b+
           Repetier host v 2.1.6
           Repetier server pro 0.92.2 (hypnos33) (started from repetier host)
  • When you login over ssh with ethernet connection, what does

    sudo /usr/local/Repetier-Setup/bin/manageWifiAccess info

    sudo iwconfig

    sudo nmcli dev

  • hello
    tests results:
    raspberry server ,home screen displaying ip@ with its QRcode
    with mac adress for ethernet link ,and some times appear second QR code with mac adress and ip for wifi link but not stable 
    in can switch from home screen to wlan screen ( showing all neigbors wlan and mine), to language screen, and reverse.

    using PUTTY connected on ssh mode to ,get black screen , but no answer to any request, totaly mute

    on my front switch/router (FREEBOX brand) i can see on DHCP (screen statics adresses), the raspberry's ethernet  link connected AND the raspberry's wifi link disconnected

    using another sdhc card with raspbian, ethernet and wifi works fine , so i think there is no problem with raspberry board
  • So the driver is now detected, but seems to be unstable. Did you set the country code for wifi already? If not it might be that your channel is not allowed in the default country 00. Also how many bars do you see for your router? Since you have ethernet access as well I would suggest to try with never use access point. Otherwise it will disconnect everytime it does not see your network. This can happen more or less often. Sometimes the driver does not return any APs when queried for some internal reasons. So when you disable the AP switch it will never remove the connection directly.
  • on ACCES POINT screen, i entered 11 for channel and FRance for country  ,never AP (i remember this was the end solution for previous version)
    host name and ssid let as is .
    screen WLAN 
    authentication: no encryption,
    additional adress:none ,
    additional name server:none
    gateway : none
    networkmask: let as is
    two hours ago i totally cleared and reinstalled again repetier host and repetier server.
    server main screen show connected 3 chain links and printer's name meaning "connected".
     once connected  to local host server  then going from mains  parameters to global parmeters then wlan parameters ,i get again :"this installation does not support wifi configuration"....
    is this normal ?
  • "this installation does not support wifi configuration" is a bad sign. At startup we test if the file 

    /usr/local/Repetier-Setup/bin/manageWifiAccess exists on disk. That is the script doing all the wifi connection stuff when we call it. If it is not there you will get that message and wifi would not work of course.

    If it there and wlan is disabled you see instead "No WLAN" where the AP list would appear.

    So the bad sign is that it is that it seems to appear and disappear.

    As a test you could login with putty/ssh and run

    ls -l /usr/local/Repetier-Setup/bin/manageWifiAccess

    to see if it is there or not. 

    sudo service RepetierServer restart

    would restart server and in case it is visible you should see wlan again.

    It might be an issue with the sd card having some defects. Have seen that happening that files disappeared and reappeared during run.

    PS: Is your wlan really unencrypted, or only for testing?

  • HI
    i have connected a sdhc card reader to raspberry then start raspberry with raspbian(noobs).
    On the external card reader i put raspberry repetier server card : in this way i can visit the entire card area. i found "manageWifiAccess" file in really in its directory place.
    i try to connect with putty to but no answer : totaly mute
    well so i am going to generate a new sdhc card maybe The solution ? 
    tomorow is an another day 
    have a good night
  • Putty communicates with ssh which uses a different port then server webserver. So leave port to the default value (21 or 22 I think it is).

    It is also ok to just install the server on your good working noobs os. All you loose is the automatic access to our additional scripts which we added to the image - means no wlan settings in surface and no automatic webcam config (also we have a doc in our homepage on how to install that). Just for the case it continues making trouble, but lets first check with a different sd card. Unfortunately they are not always as reliable as I'd like to and often the main reason for failure when it once worked.

    Please also always use the shutdown command always before unpowering to prevent defects on sd card. It will work quite often without problems but then ...
  • hi
    i downloaded the more recents files from and repetier host
    setup repetier host 2_1_6
    repetier server 0.92.3 win32 (not installed)
    repetier server image 0_92_2_v18 installed on 32Gb cl10 sdhc 
    installing repetier host,i observe that repetier server 0_92_2 is automatically installed after host (repetier server 0.92.3 win32 what for ?)
    if i take a look using "program and functionalyties" i observe that in fact repetier host is 2_1_5 and repetier server is 0_92_2 .
    doing tests
    1° test printer directly connected via usb cable to host (serial connection) works fine.
    2° host is started, api key copied from front server onto repetier host , printer appear
        raspberry display wlan qcode , wifi mac@ and static ip@( from my dhcp
        on wlan screen my wlan named freecot is shown as connected, printer is plugged on              raspberry usb 
    3° movment tests from host connected,hand control,  i can see position counters evolving but printer stay rest
    4° test using front repetier server ,using control mode , counters evolve but printer stay rest
    i think i am not very far from paradise but it lack something more
  • connect via putty ( static wlan adress) i can login to raspberry and restart by entering "sudo service RepetierServer restart" but no change : no printer move
  • The windows server is not needed when you use it on a pi also you could use it to do fast computations. In host installation is a checkbox if you want windows server or not.

    First to search why printer does not move check console. What do you see there? Send test command like M115 and see if you get a response.

    Did you use the correct firmware in printer configuration? Repetier-Firmware setting on Marlin will cause that nothing works.
  • hi
    first i must thanks you  for your help 
    1°) below  is the response to M115 command
    9:42:56.277: PrinterMode:FFF
    2°)for firmware type, i tried the four possibility unsuccessfully then let it on auto detect.
    i continue to search...
  • If you see that in console you are successfully connected. Firmware is Repetier-Firmware, also it is an old version.

    Is the result from testing on host directly or using server connector? Connection should work on both. If you use it on pi test in server console and send commands and moves and see if you get any errors.
  • hi
    i sent an "M115" command and obtain this 
    13:45:34.890: PrinterMode:FFF

    i am connected but from host, no way to get movment neither from front end server

    if i connect printer directly to host on serial mode (without raspberry server) ,thats works fine......
  • i look at printer configuration , at bottom of connexion panel there is "firmware values automatic detection .....waiting connection " which is blinking 

    method connection = serial
    device/port            = virtual cartesian 
    is it right ?

  • one more observation.
    repetier host ,show printer connected, manual control screen, blinking from "idle" to "offline" permanently
  • device/port            = virtual cartesian

    that is not your printer. It is a fake printer to test things without using a real printer. No wonder it does not work:-)
    You need a port name that looks like /dev/serial/by-id/...

    Also now that I know firmware is from virtual printer make sure to select right firmware. Might still be marlin and as said before repetier on marlin will also not connect.
  • Repetier said:
    device/port            = virtual cartesian

    that is not your printer. It is a fake printer to test things without using a real printer. No wonder it does not work:-)
    You need a port name that looks like /dev/serial/by-id/...

    Also now that I know firmware is from virtual printer make sure to select right firmware. Might still be marlin and as said before repetier on marlin will also not connect.

    thanks for your help this is very informative or helpfull for me thanks again

    thanks and regards
  • et encore une fois, cela fonctionne bien maintenant mais je ne suis pas sûr de savoir pourquoi !!
  • as used, i say a very big thanks for your help
    now  i am going to buy and register a license . i hope that will keep stable !!
  • jyb said:
    as used, i say a very big thanks for your help
    now  i am going to buy and register a license . i hope that will keep stable !!
    jyb 9apps cartoon hd
    Everything was going fine, but now I am not able to figure out whats the exact issue.
    I have searched all over the internet no sadly no solution seems to really work out.

    Any help will be appreciated.
  • @namanjohnson101 You did not say what your problem is. Assuming the problem with using virtual printer instead of real one was solved.
  • I also have an issue with the wifi connection on Raspberry Pi, i am unable to get access to the Access point, it says incorrect password.
    1. Installed Repetier-Server 0.93.1
    2. Wifi Region selected as US (My location USA, California)
    3. Wifi Channels tried (11,9)
    4. WLAN page on the Raspberry Pi does not show any WiFi networks, it did 1 time and has not come up again.
    5. Access Point keeps saying incorrect password. i tried these passwords. "12345678" "12345678." Neither works. This was attempted on my cellphone(Apple Iphone X)
    6. I changed USB ports for wifi adapter(Edimax)
    So how do i get this working on my WiFi USB dongle vs the hardwired option? I am stumped as to why this wont connect.
  • jyb said:
    one more observation.
    repetier host ,show printer connected, manual control screen, blinking from "idle" to "offline" permanently
    Yes right facing the same.
  • Ok, access point problem is a known issue we fix with next server image where we switch from network manager to hostapd where we seem to not have the problem. I'm currently working on the release of that. Until then you can follow the solution from our faq:

    see bottom answer for access point solution.
  • bonjour je suis surpris de voir autant de messages sur ce sujet.
    j'ai passé quelques jours pour enfin réussir à connecter deux ordinateurs, un chez moi et un dans mon atelier via wifi de chaque côté, à mon imprimante maison avec carte mère "lerdge k".
    Maintenant, cela fonctionne bien, également avec une caméra USB très bon marché, le tout sur la framboise fonctionne très bien.
    Mais j'ai remarqué que lorsque tout va bien et que je laisse l'imprimante sous tension et connectée, il n'y a aucun problème, je peux éteindre et allumer les ordinateurs, le système reste stable.
    le problème apparaît lorsque j'éteins l'imprimante. au redémarrage, aucune connexion possible. rien, pourtant aucun paramètre n'avait été modifié avant redémarrage ..
    après de nombreux tests, j'ai constaté que le redémarrage du serveur framboise en utilisant, dans l'hôte répétitif à partir du menu de l'imprimante (pas le menu du serveur local, qui est arrêté), je me connecte à l'imprimante. Il semble illustrer que cela est dû à la connexion de retard en mode AP? 
    au début je n'avais pas compris que le serveur local n'est pas utilisé quand il y a un serveur framboise, un répéteur-hôte se connecte directement au serveur framboise, c'était confus pour moi
    je suis maintenant très satisfait
  • Please login with ssh on your raspberry and run
    sudo apt remove modemmanager

    We detected that the presence of the modemmanager is a problem when you enable the printer. It tries to connect too to printer and disturbs communication.
  • ok i will do this asap
    thanks a lot
  • hi
    i see that new version 0.94.0 is available , i downloaded it ,but one question: does i must  type "sudo apt remove modemmanager" before running server ?
Sign In or Register to comment.