Moving extruder to different position after homing

I am brand new to the world of 3D printing and an electronic novice to cap it.  However, I thought it would be interesting to try and build my own kit printer and very successfully built a Zonestar Prusa-i3 printer.  Everything worked first time and I enjoyed doing my own designs in Tinkercad and printing it. Then disaster struck...
I changed the nozzle and broke off the new nozzle in the heat block.  Got a new heat block and then a series of problems followed. I eventually broke the thermistor and had to replace it.  I did not turn off the printer before soldering in the new thermistor and my temperature reading then stood at 248 dec Celcius, irrespective of the resistance across the thermistor connections.  I then concluded that I must have blown the Melzi board that was standard with the printer.
I got a new MKS Gen L board from the local electronics shop and started to transfer all the connections to this board. All is fine so far, except:
- My extruder motor won't work. From some responses on this forum it appears that it might be because I am trying to test it without heating up the hot end. I will try that and I hope it resolves my issue. The motor is fine - it works if connected to the Y or X axis.
- After much fiddling I got the proximity sensor on the Z-axis to work.  My problem is now that when the X and Y position is at 0,0, the proximity sensor is off the bed and cannot home. Currently I hold a piece of metal below it for testing purposes and it senses the metal and stops Z movement.

My question after this long winded story: After homing X and Y, how can I move the head to a more central position over the bed so that the proximity sensor on the Z-axis will be able to measure on the bed? I need to move it approximately 5cm to the right on the X-axis and about 3cm back on the Y-axis for it to find the bed.

I assume it just a configuration setting in the firmware - I just need to know where and how.

I will appreciate any help, thanks.

Comments

  • edited July 22
    In the firmware config tool, ( https://www.repetier.com/firmware/v100/index.php ) If you choose one of the homing options that include pre-heat (you can set this to zero so it doesn't heat) then you get the option to enter the X Y coords for when it homes Z.
    Also, have you set the probes X Y offsets in the config then firmware will move the probe the the nozzles location to home Z.

  • Thanks for the response MartinH.  I looked in the configuration tool and I think I found the parameters that you refer to.  I will unfortunately not be able to test it soon, as I will be out of town for a few days.  I will let you know how it went when I have tried the new config.
  • MartinH said:
    In the firmware config tool, ( https://www.repetier.com/firmware/v100/index.php ) If you choose one of the homing options that include pre-heat (you can set this to zero so it doesn't heat) then you get the option to enter the X Y coords for when it homes Z.
    Also, have you set the probes X Y offsets in the config then firmware will move the probe the the nozzles location to home Z.

    Thanks a lot MartinH, that was exactly what I missed.  Without pre-heat you don't get the homing options and you can't adjust the offset.  I have made my first test print and that now all remains is calibration of the extruder (it over extrudes).
Sign In or Register to comment.