Endstop not on zero


If my endstops are not on the real bed zero, lets say, it is 30mm over it (hits endstop 30mm away from the bed).
There is an option so I can set this so the printer does not print in the "air" ?

Thank you very much.


  • You have 2 options. If you do not want nozzle at all outside bed just set 
    #define ENDSTOP_X_BACK_ON_HOME 30

    If all you want is that 0 is where bed starts set x min to -30 so 0 is over the bed and you can also move outside bed.
  • If you mean the Z endstop is to high above bed, only option is to move the Z endstop.

Sign In or Register to comment.