Switched to Repetier-firmware from Marlin, now connection problems in Repetier Host

Hi there.  Sorry for having to make this thread but I've searched high and low for a solution and wasted a lot of time trying to figure it out but I'm totally stumped (and a bit frustrated).  I appreciate any help anyone can offer.

A little background:
Printer is a Prusa Mendel v2 I built back in 2013 running Marlin on a Sanguinololu board.  Been spending some time lately getting it dusted off and printing well again and decided to modify/update the firmware.  I cannot for the life of me compile and/or upload Marlin firmware on any version of arduino IDE, so I decided to go with repetier firmware since it appears to have become a lot more user friendly from when I first tried it when I built the printer.  The configuration wizard is genius and the documentation is excellent!  I really want this firmware to work and it needs to because with the compiling problems I'm having with Marlin, I'm past the point of no return.

My problem:
Using Arduino version 1.8.8 with added Sanguino drivers, the upload completes successfully but when I try to connect to Repetier host, I encounter symptoms of incorrect baud rate: serial comm errors with a line of gibberish.  Problem is, I've tried every possible baud rate in both firmware and host software with no change in error message.  Started with 115200 that I was running with Marlin, nothing.  Tried 250000, no change.  Went to 9600, nothing.  I'm changing the value in configuration.h and in the printer settings.  I've tried changing com ports in device manager, no change.  Printer was printing previously in the day on Marlin firmware, so the only variable that has changed is the firmware.  Same USB cord, same USB port, same computer.  I've searched high and low on google with everything pointing to baud rate mismatches, but that doesn't help.  I've uploaded stock repetier firmware (no changes) and customized firmware for my configuration and no difference in result.

Anything I could be overlooking here?


  • Do not forget to change eeprom mode so changes in config are copied to eeprom. Try with 115200 baud and try. In that case you can also try with arduino serial console and should see a wait every second. Then host should also work fine. My guess is that it reused old eeprom with nonsense baud rate. So set eeprom mode to 2 if it was 1 and reupload and check.
  • I really appreciate the response, Repetier.

    Got around to trying your suggestion today and unfortunately, the result is the same regardless of what mode EEPROM is set to.  After "upload complete" message, the arduino serial monitor shows [][]b that repeats every 1/3 second over and over, so I can only conclude that junk is being uploaded to the chip.  

    I'm going to ditch the Sanguinololu and get a RAMPS 1.4/MEGA to replace it since it has native arduino support.  I'm not smart or savvy enough about this kind of stuff to keep troubleshooting a seemingly minor problem I really don't understand.

    Thanks again for the response and if any other possible solutions come to mind, let me know.  In the meantime, I'll order the new electronics and attempt to get the repetier firmware uploaded.  Once I'm back up and running, I'll send another donation your way.

Sign In or Register to comment.