M212 is not changing

Anyone have any idea why out of all the commands M212 would not be working?  Everything else works fine, I can change M92, M201, M203, M210 and M211 but when I attempt to change M212 it does nothing. 


  • Most likely your firmware does not support it. Only some printrbots support it, it is not a general available command.
  • I'm running a Printrbot Simple Maker(1405) with a Rev. F4 board with stock firmware in it, can you tell me if that is the issue?  Printrbot forums are telling me Printrbot Metal and Wood should be the same though I've only ever seen it done on a metal.  The spacer I was given to shim my auto-leveler is to thick(2mm), as far as I know the idea is I'm supposed to dial it in using M212.  I updated my Repetier-Host last night from version 1.0.6 to the latest and greatest and found there is now a setting in Printer Settings for the z-offset but is it the same as M212?  Will it do anything if I change the value?
  • Something else strange has happened since updating Repetier-Host, the first time I shut it off and reopened it, it no longer can connect to the printer.  I had to change the port the usb cable was plugged into in the back of my computer.  Could something in the update have caused this or is it more likely my usb port is failing now?
  • Well I tried the setting in Printer Settings, though it seems no matter what value I put in the z-min stops at zero, it won't go any further than that, I can see in the G-code where it is supposed to be lowering the head down but alas zero is it's minimum which is still too high.  So I assume that the issue with the firmware is that it will not allow the z to move to a negative value.  Is that correct?
  • Well that was dumb!  Me I mean, I was hitting M501(Restore) to show my settings after setting M212 for some unknown reason.  I meant to hit M503(Report).  I have a brand new issue now but I'll start a new post as it's not relevant.
Sign In or Register to comment.