Heater decoupled + PID autotune

I'm having problems with "heater decoupled", I lost 2 prints already then started a test battery.
Soon as the problem happens the print stops, then there is a "dec" in the actual temp.
Without touching anything, just reseting it comes back measuring normally, so I dont believe it is a contact problem, but I checked and rechecked all cables and connectors.
The problem happens randomly, I simply cant say what triggers it.
I'm using a simple PC power supply, which is not the ideal but it was working until yesterday, so its strange.
The temp graphs looks very bad to me, but I have no knowledge about this.
After searching over internet I found something about PID autotune, I runned "M303 P0 S235 X0", after this the graphs looks much more stable.
Those swings in the temp can run to a "heater decoupled" error?
Do you think I have "treated" the problem?
Thank you very much.

Here are the temp graphs.

Only extruder:

Extruder + bed:

Printing (extruder + bed):

Print paused:

Printing 2:

Printing after PID autotune:


  • If you compare printing and non printing graphs you see much jitter when you print. This jitter makes the normal pid not work efficiently so it swings much more then normally and can reach the limits to trigger decouple. Also print quality will not be as constant with these swings as it should be. At least that is what I assume - a bit hard to see on 60 minute images. 10 minutes would be better for resolution to see if jitters are faster then real temperature changes to be expected.

    As a solution try twisting the 2 thermistor cables on the way to the board. Do the same with heater and motor cables. This reduces cross talk which I assume are the reasons for the spikes. Sometimes also nearly broken themocouples can add such a jitter. Especially if it was jitter free in the past that is more likely.

    What I'm wondering about is that bed also seems to jitter, also hard to see with the average color behind it. But you also see clearly the jumping output caused by it. Only the fact that is not as fast as extruder makes it stay at target.
  • Thanks for the tips.
    About the bed I dont know what to do, I'm aready using shielded cable, and as far as I know it does not use PID as default for bed.
  • See in eeprom which heat manager you use. For bed you can also use 0 which is simply on off. Should be no problem.
  • I use the online config tool, it is selected "bang bang" for the bed.
    There is any tool similar to the "PID autotune" for this?
  • Bang bang has no parameter so no autotune required. But check in eeprom editor if it was copied or if heat manager is still set on 3.
  • I will check, but by looking the behavior of RAMPS LED for bed and extruder I believe the bed is really in bang bang.
Sign In or Register to comment.