Please help with Z-Probing

This is my printer, it's a DIY Felix printer design, Please refer to the attached images.

This is my configuration.h

#define ENDSTOP_X_BACK_ON_HOME 35
#define ENDSTOP_Y_BACK_ON_HOME 20
#define ENDSTOP_Z_BACK_ON_HOME 5

#define X_MAX_LENGTH 158
#define Y_MAX_LENGTH 148
#define Z_MAX_LENGTH 185
#define X_MIN_POS 0
#define Y_MIN_POS 0
#define Z_MIN_POS 0
#define PARK_POSITION_X 35
#define PARK_POSITION_Y 20
#define PARK_POSITION_Z_RAISE 5

#define ZHOME_X_POS 35
#define ZHOME_Y_POS 20

#define Z_PROBE_Z_OFFSET 2.7
#define Z_PROBE_Z_OFFSET_MODE 0
#define UI_BED_COATING 1
#define FEATURE_Z_PROBE 1
#define EXTRUDER_IS_Z_PROBE 0
#define Z_PROBE_DISABLE_HEATERS 0
#define Z_PROBE_BED_DISTANCE 5
#define Z_PROBE_PIN ORIG_Z_MIN_PIN
#define Z_PROBE_PULLUP 1
#define Z_PROBE_ON_HIGH 1
#define Z_PROBE_X_OFFSET 32
#define Z_PROBE_Y_OFFSET 0
#define Z_PROBE_WAIT_BEFORE_TEST 0
#define Z_PROBE_SPEED 5
#define Z_PROBE_XY_SPEED 150
#define Z_PROBE_SWITCHING_DISTANCE 5
#define Z_PROBE_REPETITIONS 2
#define Z_PROBE_USE_MEDIAN 0
#define Z_PROBE_HEIGHT 1.3
#define Z_PROBE_DELAY 0
#define Z_PROBE_START_SCRIPT ""
#define Z_PROBE_FINISHED_SCRIPT ""
#define Z_PROBE_RUN_AFTER_EVERY_PROBE ""
#define Z_PROBE_REQUIRES_HEATING 1
#define Z_PROBE_MIN_TEMPERATURE 0
#define FEATURE_AUTOLEVEL 1
#define FEATURE_SOFTWARE_LEVELING 0
#define Z_PROBE_X1 -37//-20 // 35
#define Z_PROBE_Y1 20//-40 // 20
#define Z_PROBE_X2 158//70
#define Z_PROBE_Y2 5//-20
#define Z_PROBE_X3 -37//0
#define Z_PROBE_Y3 143//80
#define BED_LEVELING_METHOD 1
#define BED_CORRECTION_METHOD 0
#define BED_LEVELING_GRID_SIZE 3
#define BED_LEVELING_REPETITIONS 5
#define BED_MOTOR_1_X 0
#define BED_MOTOR_1_Y 0
#define BED_MOTOR_2_X 200
#define BED_MOTOR_2_Y 0
#define BED_MOTOR_3_X 200
#define BED_MOTOR_3_Y 200
#define BENDING_CORRECTION_A 0
#define BENDING_CORRECTION_B 0
#define BENDING_CORRECTION_C 0
#define FEATURE_AXISCOMP 0
#define AXISCOMP_TANXY 0
#define AXISCOMP_TANYZ 0
#define AXISCOMP_TANXZ 0

with this config, when I send G30 am always having the error of:
Error:Activating z-probe would lead to forbidden xy position: -33.000000, 0.00

My print bed couldn't reach the 0 position because of its limited size so I need to back on home at 35mm for X and 20mm for Y.
Why it's 35mm for X is because I need to position my inductive sensor inside the alum bed.

Thanks in advance for the help.

Images link: https://ibb.co/SPDdS4r

Comments

  • As your probe is located to the left (-) of the nozzle, the X offset should be negative in value 
    #define Z_PROBE_X_OFFSET -32

    Also i think your X1 and X3 probing locations need to be positive.
    min/max values changed to put probe inside bed edge
    #define Z_PROBE_X1 40
    #define Z_PROBE_Y1 25
    #define Z_PROBE_X2 150
    #define Z_PROBE_Y2 25
    #define Z_PROBE_X3 40
    #define Z_PROBE_Y3 143

    Also use a homing order that uses a preheat option, then you can specify the X Y location to probe Z home.

  • edited May 9
    Thanks @MartinH for the reply. I changed the values of my configuration based on what you have suggested but still am having the same issue. I have prepared a video to see exactly what is going on with my printer.


    in case of probe Z home I have put:
    #define HOMING_ORDER HOME_ORDER_XYTZ
  • On my prussa my X endstop is about 25mm off the left of the bed, so i set my X min= -25 and the X home = 0.

    You could try

    #define X_MIN_POS -35
    #define Y_MIN_POS -20
    #define Z_MIN_POS 0


    #define ZHOME_X_POS 0
    #define ZHOME_Y_POS 0

  • Hi @MartinH, Thanks again for the response.
    I've tried your suggestion but when I home Z, I got the same error right away. Earlier values are better I think this time. What could possibly wrong with my printer? Am using 1.0.3 FW version.
Sign In or Register to comment.