Y-Axis behaves like Z-Axis

Hello,
I'm building a 3D-Printer right now using the Repetier firmware. 
Always when printing a file my Y-Axis moves around in ways it shouldn't. It seems like it moves for- and backward between each layer. And when this happens just the Y-Axis moves between layers, not the Z-Axis. When i controlle the axis manually, everything workes fine. 
Is there any solution to this problem?

Comments

  • I still have this weird Issue, althoughmy Z_Axis now moves, the layers are still shifted really bad
  • So you can move x, y, z separately and all move correctly. But if you do a small z move y moves instead?

    If you have only one extruder I suggest connect stepper for y to that driver and set y axis driver to E1 driver and see if it gets better. That normally does not happen and I want to exclude a hardware failure like cross signals to y driver with the test.
  • Helllo,
    the Z-Axis not moving problem was resolved with reinstalling the firmware. It no moves fine, but my prints still come out slanted. I tried reducing the Jerk down to 6 and the acceleration down to 650, but the more i Reduce them, the worse it gets.  However, I now only got these slants in the x-direction. The y-dricetion is completely fine, although it uses the same leadscrew setup. I changed the X with the E2 port on the board, but nothing happened.


    This is again my 1cm3 testcube, which I resliced a few different times, and from left to right i reduced the speed and jerk settings.
  • I found this thread http://%20https//forum.repetier.com/discussion/905/have-had-someone-such-a-problem
    And so i went and increased the delays a bit (picture) and now the printer does not move to the center anymore when starting a print, although it did before and I'm still zusing the same gcode files ( I tried new ones too - same problem)
  • Maybe you should give some informations about the hardware. E.g. 280steps per mm at 200mm/s as you set as maximum is 56000Hz which is not possible with a 8 bit controller. With the delays it is also not possible. Delays are only required for slow drivers.

    Have you checked the motor current? If drivers get too hot they start not executing all steps. Just one possible reason. If it is not high enough it will of course miss some steps.

    Set ALWAYS_CHECK_ENDSTOPS to 0 so no cross talk to end stops can stop moves. At least until you find the source of the problem.
  • The drivers should all be A4988. The ramps board is set to 1/16th microstepping and the Nema 17 stepper motors do 200 Setps/revolution. 
    I tried setting ALWAY_CHECK_ENDSTOPS to 0, but it made no real difference at all.
    Is there a good/software way to check the motor current? I don't think that the driver should overheat, because I have a fan blowing air at them and their heat fins don't get hot to the touch.

  • As far as I remember the allegro drivers are fast enough to work without delays. Only way to check current is with a multimeter checking reference voltage and check with datasheet how much current that means.


  • edited April 26
    I'm really confues. It get's crazier and crazier.
    In the begining, when using Repetier, my printer moved to the center of its bed and started printing there. Now it just stays near its zero position (and I'm still using the same gcode files). 
    Furthermore, when printing the stepers still move around like crazy. 
    In these pictures I tried printing a 20mm calibration cube with a brim and this happened. The printer moves further and further to the side (in this case the y-direction). 
    I just don't know whats going on.
    This is the repetierfirmware config running on my printer right now:
    https://reginogymnasium-my.sharepoint.com/:f:/g/personal/haas-sebastian_regino-gym_de/EmYgwZX1vcREgoZlp4B5f40BG4dtUb8Ax2E2C6zVDJBhZA?e=LTup8G



    Edit: I also went back to version 0.92 to, but still the same results, that seem like as if the printer prints the layers next to each other and not on top of each other.
  • edited April 26
    I did another print run with the 1cm³ cube. During the print the printer started hitting the Xmax-Endstop. You can clearly see the point where itstarted hitting the endstop, because then the layers work out fine, but before that they're shifted really heavily.

    Could ther ebe some really weird crosstalk between the drivers, that makes the other axis shift between layers?
    I'm again printing a testcube right now and the Y-axis just wanders of far away from the startpoint.
  • seems you are loosing steps .

    check Motor current

    https://www.derpade.de/3d-drucker-a4988-motortreiber-stromstaerke-einstellen/

    next : try to reduce acceleration to 100 , iand then increase from there


  • Hello,
    So i finally got to adjusting the Motor current. I played around with the values and now it's working better during printing, but when homing the axis now get stuck.
  • More details pease if you want help.
  • When the printer tries to home, the X and y axis start moving, then get "stuck" on their axis a bit before the endstop. The there is a loud scrapping noice and i usually push the sledge on the axis towards the endstop. Close to the endstop the axis works fine again. It happens on the X aswell as the Y axis, they're not scrapping against anything, I even tried homing to min and max endstops, but always the same thing but in different places
  • Is it easy to block the motion and do you then get the same sound? Sounds like your steppers are loosing steps due to increased friction near end stops. So now your current is too low then.
  • Today I tuned my stepper currents further. I raised them a fair bit and started cooluing the motors. It works fine for printing, but homing is still meh. But that's not really a concern anymore. It workes a bit better now and it's good enough for now.
    Thank you all for your support.
Sign In or Register to comment.