Z-Probing, Correction matrix and Z-Home

edited April 10 in Questions & Answers
I am facing an issue with 1.04 or so.
"ALWAYS_CHECK_ENDSTOPS" seems to not working anymore for movements.

In fact it is still check at movements. 
Just home the Printer and try to go below 0.0mm in Z in the "Move" Panel. Does not work anymore.
With "Slow" you get -0.01mm but thats it.

The effect in Print: If you need to go below 0.0mm (i.e. -0.05mm) because of Leveling/Correction matrix, this move is not executed. No Error, no nothing, Z still at 0.0mm, just not moved. But going up is working. So you constantly going away from bed, going out of sync. In the test I'm printing you end up with arround 0.6mm Z away from bed in the first layer. :(

You don't even home the printer. Just go away from bed, switch off/on, try to move below 0.0mm. Does not work.
snipped from my configuration.h:
...
#define ENDSTOP_Z_BACK_ON_HOME 0
#define ALWAYS_CHECK_ENDSTOPS 0
#define MOVE_X_WHEN_HOMED 0
...

Oh, I'm using Visual Code to compile firmware. Good move, I really like it. :D

Comments

  • There is also the test isPositionAllowed allowing a tolerance of 0.01mm - just what you said you can do in slow move. So this test is preventing move when manually moving. So that part at leats is correct. It is not supposed to allow you go below 0. Sending G1 S1 disables destination check if you have good reason to violate that rule.

    These tests are executed on global official coordinates, so they should still do internal bump correction even if it goes below bed. Probing also is not affected by the position test so will probe below z=0. Yes you can not move below 0 without homing which restores right bottom. Same for X- and Y- direction. Actually I would even recommend disallowing motions before homing at all. There are now switches to prevent that.

    Can you explain the leveling error a bit more. That is the only thing that does not seem to work as expected. During leveling/bump mapping you should start from a level well above z=0 after homing. z probe goes always back to start height. Why should it always go higher. What is your exact test sequence here.
  • I will do some double check today.
    I will disable correction matrix first, than ABL and let you know the results.
    As of now I am not really sure what happens. All I can see is the behaviour described in first post.


  • @Repetier,
    sorry for late reply.
    I doubled check the next day and it is working as expected. This is really crazy. I do not have an idea what happened before...
    Anyway, I keep an eye on this.
Sign In or Register to comment.