Delta printer stopping shortly after print start

Hi,

I have a 3d printer that i made with parts from ebay, 310mm bed, arduino mega and RAMPS 1.4 with DRV8825 stepper drivers, 12V 360W power supply. I run repetier firmware with repetier-host.

It's been printing fine for about 2 years. I solved everything that came up, to the point that i could just leave it printing and go and do my other things.

Recently, it started randomly to have a problem, when i was starting a print, after about 15-20 seconds, it would just stop printing without any error. The extruder and bed would get set to 0 degrees and the steppers would stop, almost seemed like somebody pressed the reset button.

Now it's doing it more often. Occasionally it will finish even a 2h print, if it gets past the first 30 seconds without stopping. I don't know what i would need to change. Please give me an idea. 

I'm printing in PLA extruder 210 and bed 60.

PS: I thought it would be something set wrong in repetier-host (no error appears in log file). So i fired up Simplify 3D, and looking at the communication windows, when the problem occurs, it would say RECEIVED: wait. And this message would appear once every second until i exit the program.

Maybe something is fried on the RAMPS board? I have the bed wired through the board, maybe i should go with a relay instead in the future. 

Thank you,
Cristian

Comments

  • I just installed a new PSU and it does the same thing. So much for that, i guess it's the either the arduino or the RAMPS. What do you think?
  • edited April 14
    You could try reseating the boards together. I had a weird issue similar to that, and separating and reseating the boards cured it. Like you my setup was working fine for a number of years. Just a suggestion.
  • "wait" just means printer is idle awaiting new commands. You should look for "start" which would appear as a sign of a reset. It will also write out reset reason.
  • it just gives a wait message per second, so it's not followed by a start.

    I replaced the PSU, then RAMPS 1.4 and now the arduino mega... and it's the same. Silly bug.
  • Looks like it started working after i reduced the printing segment/s from 180 to 100. I printed for almost 3 years with 180 and didn't had any problems. I don't understand why it would be a problem now. But it work with the new 100 segments/s setting.
  • Was the problem always at homing or first command after homing? It is strange that it happens only in the first 30 seconds so it must be something in the initialization. Did you update firmware before problems started? As you said it is strange if it always worked and suddenly not.
Sign In or Register to comment.