v0.91 - Touchscreen goes to screensaver regardless of setting 0

Hi,

With the latest version i noticed that my touchscreen goes to screensaver after about 10 mintues. I had previously disabled screensaver by having a time limit set of zero. Now it seems regardless of this setting a screensaver is applied after a few minutes and i can't seem to turn it off.

Not a huge issue but it was not there in the last version.

Cheers

Comments

  • Ok, found reason. We have a new script for screensaver and that is not in sudoers list. Over ssh send
    sudo echo "repetierserver ALL=NOPASSWD: /usr/local/Repetier-Setup/bin/screensaver" >> /etc/sudoers.d/repetierserver-perms

    to fix. Then set timeout 0 and disable display should be disabled. You need to toggle if it is already. Then it will work.

    Next update will fix it automatically.

  • When i send above command i get following permission denied response:

    pi@RepetierServer:~ $ sudo echo repetierserver ALL=NOPASSWD: /usr/local/Repetier-Setup/bin/screensaver >> /etc/sudoers.d/repetierserver-perms
    -bash: /etc/sudoers.d/repetierserver-perms: Permission denied
  • In your variant the quotes are missing!
    sudo makes you root so you should have all permissions. You can also edit the file and add the line manually
    sudo nano /etc/sudoers.d/repetierserver-perms
    and add line
    repetierserver ALL=NOPASSWD: /usr/local/Repetier-Setup/bin/screensaver

  • In my original try the quotes where there but same result. Not sure why they were gone from the version i pasted here. Regardless i now did the edit with nano and it seems to work now fine. Thanks!
Sign In or Register to comment.