ABL and Correction

First of all, great job on integrate auto bed leveling and correction and probe heigth into "Setup". It's really easy now, no more extensive calculations (just a suggestion: update the repetier-firmware-Z-probing documentation, it's obsolete now, isn't it? :))

Now my question. I do have a cartesian CoreXY, BLTouch attached on Z-Max endstop and both auto bed leveling and correction is working great.
I'm just wondered about proccedure. First I measure Z-probe heigth for sure. Than I do the bed leveling and after that I do corrrection. Should I disable active bed leveling when doing correction? Or leave it on or doesn't it matter?

btw. I was struggling with correction matrix. I tried to measure results with Gage blocks and could not see any difference, I know the bed is about 0.1mm bump in the middle... Until I realized degration. ;) Next is the "going down" for every new measure point until I realized it's "ZHOME_HEAT_HEIGHT". Unfortunately you can't configure this with Web firmware-configurator (at least I did not find it, may I'm blind).  

But again, great job it works like charm here. :smiley: 

Best regards,


  • Distortion correction is always on top of bed correction. Bed correction undoes bed rotation - distortion vanishes over height but you still want the much bigger rotation error fixed everywhere.

    ZHOME_HEAT_HEIGHT is just for heating so nozzle does not touch bed. Some bed covers can melt with long contact. Also don't see it in config tool. Will check when I'm back.
  • edited February 2019
    Thanks for explanation.

    I do have one more issue with correction matrix which seems to be a bug.
    As soon as I have correction matrix enabled, the extruder acts different for the first few layers.
    It does not work "smooth" over a command anymore. Instead it starts extruding with a new command but stops extruding right after the start but the movement (X/Y) still works to the end of the line.
    It's a bit complicate to explain. Hopefully you have an idea what I described.

    Best regards,

  • Which version do you use? 1.0.3 or development? At lower layers long moves are split into 10mm segments, so from your description it sounds like the first segments does e move and remaining stop doing so.
  • Also do you extrude absolute or relative. Might make the difference for the bug.
  • edited February 2019
    Yes, your description sounds like the issue I have.

    I use 1.04dev from yesterday.
    Last 1.03 (from weekeend) crashes into X-endstop when homing, verified on two printers.

    This evening I can double check if extrude is using relative or absolute. Should be in the gcode file, right?

  • Ok, I have found the problem. Had to to with my advance improvements. A variable that should be float was int so positions were rounded to full integers. Not good. Is now fixed in 1.0.4.
  • edited February 2019
    Great News. :D
    Will update and let you know if it is fixed here.

    Edit: Looks good, working now as expected. :D
Sign In or Register to comment.