Setting different E-Steps when using Ditto mode

Dear community

I want to use the ditto-mode to print two parts at once with my two extruders.
The problem I currently have is that one extruders has slightly more steps/mm than the other one (about 4%). I think the reason might be a difference between the diameter of the two extruder gears.

I´ve set the E-steps of the each extruder correctly, but in ditto-mode, both extruders are using the E-steps of the first extruder, so that the second extruders extrudes too much material.
Is there an option to modify the ditto mode so that both extruders keep using their individual E-steps?

Thanks in advance

Legion 23

Comments

  • That is not possible in V1. All steps are copied 1:1. In V2 we plan a solution to this with a virtual  e step for all and individual e steps for extruders. That way it could be made, but also that is not implemented now.
  • Would it be possible to work with the "mixing extruder" - feature?
    For color mixing extruders, the extruder motors can run with different Steps/mm as described here: "https://www.reprap.org/wiki/Repetier_Color_Mixing".

    When I try to work with the firmware configuration tool, the PID-Values and temperature sensor settings disappear when I select the "mixing extruder" - feature. Would it work to simply change "#define MIXING_EXTRUDER 0" to "#define MIXING_EXTRUDER 1" in the config.h while still having the option to work with each extruder individually (setting individual temperatures and PID-values)?



  • You can only have one extruder heater with mixing extruder, so the second one would not heat. Apart from this the idea was quite good also ditto mode would require flow at 200% so that every part gets 100%. You could hack extruder.cpp to have the first 2 extruders having individual heaters but that will get confusing.
Sign In or Register to comment.