Anycubic Chiron

I am unable to connect my Anycubic Chiron printer to Host.
The connection appears to be made but no start signal is detected and a forced start is issued but I have no control over anything after that.
What am I doing wrong?

It works fine with my Geeetech i3 mk2 Pro B  and my Geeetech A30


  • Protocol ascii and right baud rate set?
  • I have Transfer Protocol set to Autodetect though I have tried Ascii and Repetier Protocol, and baud rate 115200 though I have also tried faster and slower (down to 56000).

    The connect icon turns cyan to show a connection is made but nothing else happens

  • Color changes based on the fact that windows connected the port. This does not necessary mean that there is communication. Some boards need special state of DTR/RTS pin to send data. You can try with Repetier-Server to connect. There you can already set how these flags are set. Once it connects you can then use the repetier-server connector in host to connect to repetier-server and print over this.
  • I will give that a try, thank you

  • That worked, thank you :-D
  • For interest, what DTR/RTS handling did you set in server, so it works?
  • Adrian said:
    That worked, thank you :-D
    Hi Adrian, is your Chiron still working with the Repertier software reliably?

    I want to give it a try as well, Chiron to my understanding has some serial connectivity issues as I also read some people fail with Repetier all together and Octoprint too.

    How has been your experience? 

    Hope all is well btw :) 
  • @tunc3d

    I was also having issues connecting my Chiron to Repetier, Finally got it working and it works really well. 

    I have mine set as follows

    Baud Rate 250000
    RTs High
    DTS Low
    Input Buffer 127

    I found that the main issue for me was the correct firmware selected.

    I have since flashed to Marlin but originally i was trying both repetier firmware and RepRap... 

Sign In or Register to comment.