Problems connecting by USB

Hi all,
we made our own board based on Arduino Due design (SAM3X8E controller) with TRINAMIC motorcontroller chips.
We would like to connect it by using the native USB port of the controller, but we have a problem connecting to repetier server.

Situation:
- We can connect the board to the PC by USB and install the repetier firmware using Arduino IDE
- At windows device manager the board shows up as "Arduio Due"
- Adding a new printer to repetier server fails because autodetection of baudrate fails

Anyone some ideas ?

Thanks  a lot !

Comments

  • Did you select the right firmware? The default repetier-firmware uses binary protocol other firmwares do not understand, so they give not the right answer.

    The other thing is that native port connection will not reset the printer, so it will not send the "start" on it's own. That makes the right choice of firmware even more important.
  • Thanks for your help.
    It seems to be a problem with some changes we made in our firmware.
    Using a "clean" firmware the communiction works fine, so let's start finding the bugs in our extentions.
  • Hi everyone. I have been using Repetier Host with an Anet A8 printer with no problems connecting and sending data to the printer. I have just replaced the A8 with an Alfawise U30 printer, and although it shows to be connected Gcode commands are not being sent. I just get 'x' commands waiting. What am I doing wrong?
    Thanks,

    Carloss.
  • What firmware does the Alfawise use? Baudrate set correctly?
Sign In or Register to comment.