extruder / part cooling Fan

today added the 2nd output for extruder 1 extruder 0 worked great (eventually add a 3rd extruder)  (ramps 1.4)

think the heatbed mosfet was controlling the part / extruder fan. i could turn on or Off with the repetier firmware now with the configuration change of adding the 2nd extruder the fans stay on full.

Read some place here that this may be due to adding the 2nd extruder output (dont think that is what i want as each has it own cooling fan) But this was the fan control (in general) previously working.

How do i reset so this works (used the configurator o92.9 version with the config H  (ps the one output controlled the part cooler and the fan for the extruder.  had it set to come on 25% of the time and that worked great. 

Also notice i don't have a heatbed slider anymore (this maybe related)  seems to me i am missing  or need to correct the line in configurator 092.9 someplace any ideas
not sure which portion of config h this is in, let me knwo  and i can post :>)
thanks in advance

Comments

  • HEATER_2_PIN and FAN_PIN are identical for ramps 1.4. So if you now have a heater connected where previously the fan was, you need to connect fan to a adapter I guess. So now you need to set the fan pin to the pin of the adapter you use.
  • I am using a KFB2.0 3D printer controller board which is ramps 1.4 I was having the same issue for where I had to have my extruder 2 hooked to my fan port to use the second extruder.  I have found out that if you change in pins.h for the ramps 1.3 where it says Heater_2_pin 9 to Heater_2_pin 7 then you can use the fan and the second heater they way it's suppose to work I was wondering if there is any way there can be a ramps 1.4 added to the pins.h with this change in it or atleast for the KFB2.0 board.



    // uncomment one of the following lines for RAMPS v1.3 or v1.0, comment both for v1.2 or 1.1
    #define RAMPS_V_1_3
    // #define RAMPS_V_1_0

    #ifdef RAMPS_V_1_3

    #define ORIG_X_STEP_PIN         54
    #define ORIG_X_DIR_PIN          55
    #define ORIG_X_ENABLE_PIN       38
    #define ORIG_X_MIN_PIN          3
    #define ORIG_X_MAX_PIN          2

    #define ORIG_Y_STEP_PIN         60
    #define ORIG_Y_DIR_PIN          61
    #define ORIG_Y_ENABLE_PIN       56
    #define ORIG_Y_MIN_PIN          14
    #define ORIG_Y_MAX_PIN          15

    #define ORIG_Z_STEP_PIN         46
    #define ORIG_Z_DIR_PIN          48
    #define ORIG_Z_ENABLE_PIN       62
    #define ORIG_Z_MIN_PIN          18
    #define ORIG_Z_MAX_PIN          19

    #define ORIG_E0_STEP_PIN         26
    #define ORIG_E0_DIR_PIN          28
    #define ORIG_E0_ENABLE_PIN       24

    #define ORIG_E1_STEP_PIN         36
    #define ORIG_E1_DIR_PIN          34
    #define ORIG_E1_ENABLE_PIN       30

    #define SDPOWER            -1
    #define SDSS               53
    #define ORIG_SDCARDDETECT     49

    #define LED_PIN            13
    #define ORIG_FAN_PIN            9
    #define ORIG_PS_ON_PIN          12

    #define HEATER_0_PIN       10
    #define HEATER_1_PIN       8
    #define HEATER_2_PIN       7 // changed to 7 from 9 to make heater work.
    // ANALOG NUMBERING
    #define TEMP_0_PIN         13   
    #define TEMP_1_PIN         14
    #define TEMP_2_PIN         15
    #define E0_PINS ORIG_E0_STEP_PIN,ORIG_E0_DIR_PIN,ORIG_E0_ENABLE_PIN,
    #define E1_PINS ORIG_E1_STEP_PIN,ORIG_E1_DIR_PIN,ORIG_E1_ENABLE_PIN,

  • Did you check MPX3 board? I think there is one more output for fan. Guess it could be exactly that layout.
  • Good to Know thanks forgot what i did to fix my issue. but i did check mark another default in the configuration settings. now it seems to working like before think i used the heatbed output as the control point pin since no heat bed installed.  when i switch to the radds i have to fix several pins due to several fubar thermistor inputs so that may have contribute when i set up the 3 extruders on one heater and Thermistor defaulting to zero which is really the heat bed thermistor input renumbered   to zero :>)
Sign In or Register to comment.