Bed leveling and homing w Z-min

Hello,`

I just build an hypercube printer which is a core xy system with a bed moving in the Z_direction.
I am experiencing an issue with bed leveling with an inductive sensor with is also configured as an endstop at Z_MIN.

The problem is that while printing the first layers the auto leveling seems only to work in one direction.
At the lowest layers the probe is constantly active due to the compensation by Z_PROBE_HEIGHT.
So so as long as the bed compensation moves the bed away (Z+) from the endstop it is ok. But in the opposite direction (Z-)  the still active endstop seems to prevent the movement. So instead of leveling the bed the systeem is gradually building up an offset. 
I do not seem to be able to find out what I configured wrongly.
Or is this a limitation of the Repetier FW? 
In order to confirm the above I disabled the endstop and homed manually. Then the autobed leveling works in both directions Z- and Z+. 
But I do not like this set up. I also want to have a homing function. Homing to Z max would be an option but I do not like that very much either.
So, can it be fixed to use an inductive sensor for Z_min and stop an bed leveling together.

Any help is appreciated!

Thanks in advance,
Peter
 

Comments

  • ALWAYS_CHECK_ENDSTOPS 0
    should do the trick. That way end stops are only checked during homing.
  • Thanks.
    That did the trick.
    A bit a pity that I mounted end stops at both sides. The Max sensors are somewhat useless now.
    But what the heck. The system is working properly now and the printing performance is pretty good if not excellent, thanks to the bed leveling.

    Thanks again,
    Peter
     


  • YOu can add a sensor at z max and home z max. Then z probe is not a end stop and is only used for probing.
Sign In or Register to comment.