Repetier 1.0.3 | Blank LCD after upgrading | Printer: Hatchbox Alpha | LCD: SCM12864F

edited December 2018 in Display & Keyboard
Issue: The LCD display does not work after install updated firmware. 
Printer: Hatchbox Alpha Delta 3D Printer w/E3D V6 Clone
Melzi: MKS Gen 1.4
LCD: SCM12864FV1.0
OS: Windows 10
APPS: AVRDUDESS 2.6, ARDUINO IDE 1.8.7
Original Firmware Version: 0.92.8
New Firmware Version: 1.0.3 

This is what I tried: 

1. I dumped all of my firmware settings using Repetier-Server.
2. Used Fischl USBASP with firmware v1.5 to dump the firmware and downloaded the following firmware for reference: https://www.thingiverse.com/thing:2773118

3. I then went to the firmware configurator and imported his configuration.h file since he didn't include the JSON.
4. I set the ESTEPS to 400, and reversed the extruder since I am using a Tevo Titan
5. I removed all of the extra languages but English to save space.
6. I downloaded the entire firmware package and opened it in Arduino IDE 1.8.7 and compiled the firmware.
7. Uploaded the new Repetier Firmware 1.0.3 using AVRDUDESS and once I power cycled the board I got no LCD.

I figured it could be an issue with the pin configuration causing the display not to load and I tried using the 0.92.8 source and wasn't able to get it to work because they used a super old version of Arduino IDE and it has errors. If I install their stock firmware it works fine though. I am able to compile 0.92.9 Kirby Firmware but I can't import the configuration.h file into the configurator.

How can I step upgrade from 0.92.9 to 1.0.3?

Here is a link to all the files: https://goo.gl/kRpH2R





Comments

  • Configurator only works when the configration.h was created with the config tool. If not you can still use config tool, but you need to fill in values by hand looking up from the config file you have. You always see the define name next to value name in config tool to help you.

    If I understand you right the display is the only part not working? In thingiverse config file they selected type 11 which is the RepRapDiscount Graphic Controller - the probably most widely used display if you include the compatible clones. I have no idea why they also included ui.cpp - pins are defined in DisplayList.h for displays. And the init seems correct:
    #ifdef U8GLIB_ST7920
        u8g_InitSPI(&u8g, &u8g_dev_st7920_128x64_sw_spi,  UI_DISPLAY_D4_PIN, UI_DISPLAY_ENABLE_PIN, UI_DISPLAY_RS_PIN, U8G_PIN_NONE, U8G_PIN_NONE);
    #endif

    that display uses the ST7920 chipset.
  • edited December 2018
    You are correct about the ReprapDiscount display in the Thingiverse build but just using his config imported into the configurator does not work at all. I don't think he actually got it to work because it says he was abandoning Repetier for Marlin. I have experience with Marlin. What I am going to see is if I can use Beyond Compare to match up the settings and copy them over from 0.92.9 to 1.0.3 to see if that works. I also wasn't able to get it to work with Hatchbox's config file using the configurator so hopefully this works.
  • If it works with stock 0.92.9 it should work win 1.0.3 as well. It is still the same u8glib, just added maybe some more chipset types. For display only the settings in User Interface should matter.
Sign In or Register to comment.