Two IP addresses necessary?

We installed the Image V12 with Repetier-Server 0.90.7 for Raspberry Pi, on a RPi3 B+.  We connect to the server via hard wire only, programmed our DNS server DHCP with the MAC address for a static IP, and connect to it via web browser.  This worked for a month and many prints, until we recently tried adding a camera.

We are not sure how, but somehow we caused a change while trying to add a camera.  The repetier-server now hits up our DNS server twice, and obtains two IP addresses.  For the same network interface eth0, there are two different QR codes and two different IP addresses... the same two IP addresses provided by our DNS server DHCP.  In order to get it to work, we had to remove the static IP address entry from our DNS server DHCP.  Otherwise it would connect, work for about 1 minute, and then drop connection for good.  The DNS server would deny that 2nd attempt for the same MAC address, and it looks like the repetier-server would respond by dropping eth0 entirely.  A temporary 1 minute connection could repeatedly be had by unplugging the ethernet and plugging it back in.  We could also easily connect via WLAN AP mode.  Our DNS DHCP static entry called the server by a unique name… i.e. ‘our printer’.  With that entry removed, the DHCP provides two IP addresses with the name that the repetier-server insists on: 'repetier-server'.

We are not sure how we accomplished this.  We did very little to get the camera working, and we tried unplugging it and putting everything back.  During this, we entered in a password (changed it) for the pi login, to connect via SSH and sudo nano the config for the camera.  Maybe we triggered some background software / configuration changes?  Our server name under global settings is ‘our printer’.  We do not see where the name 'repetier-server' is coming from.  We have not populated the 'Server Domain Name' field.  Without touching it, I felt the behavior is odd that it is now hitting up the DNS DHCP server twice and obtaining two IP addresses for the same network interface eth0.


  • Our static entry and server name had no spaces... more like 'our-printer'.
  • I have no idea where the second eth0 device comes from. In fact we never touched the linux configuration for eth0 since fetching it by dhcp is all we want anyway.

    There repetier-server comes from is easier. That is the hostname of the pi image. Go to wlan settings->Connection Settings. There at the top you can change the hostname to whatever you want. This gets also reported as zeroconf uisng avhci so you can enter e.g. in smartphone repetier-server.local as address if it is in same network. Windows requires bonjour support to find it that way.
Sign In or Register to comment.