Repetier server crashes at the end of the prints

It only happens with my Anycubic i3 mega but the server crashes by the end of the last layer.  It does not spoil the print (except for a little blob due tot he fact that it leaves the nozzle right on the print) but it has become an annoyance to restart the server manually after each print.  This also makes it impossible to have more than one printer connected to the server because any other printer would fail when the server crashes after the i3 mega print is finished.

I checked and rechecked the configuration of the i3 mega but found nothing special. I use different slicers on different machines with the same problem, so this should not be Gcode related.

Any ideas ?


  • Are you on latest 0.90.7 version? I know we had this problem in the past, so first idea would be to ensure to run latest version.
  • yes it is the last version 0.90.7 pro version.  I tried to erase and resinstall the printer but to no avail.  I checked the Repetier logs and they mark the event as an "external reset".

    Perhaps there is something conflicting with the stock firmware of the i3 mega that is an old version of Marlin.  The other printers do nothave this problem.  
  • What is the exact error message?

    Main question is at the moment for me if it crashes or blocks. Assuming you use it on a pi, does
    ps aux | grep tier still show it.

    If it is still running but does not respond you have a hang. If it is not running any more it crashed.

    Shows how to debug it so I find the reason. If it hangs do it as described if it crashes start server instead inside debugger

    sudo gdb --args /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml


    and it will show where it crashed and why. Then provide the backtrace (bt).
  • The server is on a windows machine.  the process was terminated, not unresponsive.  I just had to start it again. 

    Meanwhile, I did a reinstall of everything and now it seems to work back again.   It would have been intersting to know what made it terminate that way,  but user impatience killed the curiosity... 
  • Yes, would also like to know - also why reinstalling worked as definition and files keep the same.
Sign In or Register to comment.