Waveshare Spotpear & Raspi 3

Hi Folks,
I just bought a 3,5" LCD which seems to be a waveshare spotpear.
(See here: https://www.ebay.de/itm/3-5-LCD-Touch-Screen-Display-Hülle-Set-Kühlkörper-für-Raspberry-Pi-3/191598363276)
I connected it to the Pi and installed the driver, now it will show me all the console output during booting and some Kernel messages. But what it does NOT is show any interface from Repetier. 

So do I have to configure anything else? 
I just found this, but I think it migh be an older version and is outdated (I'm using the latest version of Repetier):
https://www.repetier-server.com/booting-into-touchscreen-mode-for-linux/

Can anyone help me to solve this issue and get my screen properly working?

Regards,
Maeffjus

Comments

  • You need to tell x server to use a different display. See last answer here:
    https://raspberrypi.stackexchange.com/questions/34426/gui-on-hdmi-monitor-doesnt-work-after-installing-the-lcd-display-drivers

    it is something like this.
  • Seems like you guys know your product very well!
    In fact this is impossible:
    "Try this to switch back to HDMI Output: Run "sudo nano /etc/X11/xorg.conf.d/99-fbturbo.conf"."
    The files are under /usr/share/X11...
    Anyways, I ended up re-installing the whole server. Still not really working.
    Now I see the shell output and then it goes to a blank screen with a cursor in the upper left. In the beginning there is some circle in the screen flickering, then it stays blank. (So only the cursor stays there)

    What can this be - no idea how the interface for the server is loaded..
  • edited October 30
  • Sure...!
    I did plenty of times & installs now - again and again.
    Anyway, what happens in fact is:
    When I press the display, for a very short moment (probably when it refreshes?) I can see the menu.
    I guess the direction-arrows are displayed, because the bed moves a bit.
    But all the time I can see the cursor (not sure about the refresh-moment), so I can exclude any faulty contact.
  • OK, as far as i know there are two versions of this display .
    -was there a cd included ?
    if yes , did you use the driver from cd or a downloaded one?

  • No, there was no CD, I tried A & B (V2), this just inverts the colors.
    So still no idea whats going on :-/
  • so it might get a riddle...

    i remember some of these displays were quite tricky to install but i have to search which one it was.
    whats indicated on the display ? is it A or B
  • edited October 30
    ok, found something.
    just take a fresh , unmodified installation.

    Sudo nano /boot/config.txt

    attach following line at the end of file :

    dtoverlay=piscreen,speed=32000000,rotate=270,fps=20

    save file.

    Sudo nano /boot/cmdline.txt

    at end of first line attach:

    fbcon=map:10 fbcon=font:VGA8x8 logo.nologo

    save file


    Sudo nano /usr/share/X11/xorg.conf.d/99-fbdev.conf 

    add following lines:

    Section "Device"
     Identifier "TFT"
     Driver "fbdev"
     Option "fbdev" "/dev/fb1"
    EndSection



    save file and reboot, that should do the trick

    you can also try to add just  the last part to your existing installation, might be enough


  • Not sure, it says V4 :-)
    Anyway, I have downloaded a image which contains the driver and its working, I got the desktop of Raspian.
    Buuut: When installing the deb-file with dpkg, the server does not start and I can not start it from the shell. Also no GUI is loaded and as well it is not available via the web-interface.
    Any idea here? :-)
  • so may be just use the repetier server image and follow what i suggested.
    that´s how i got my display to do the job on repetier server image.
  • Hmm, yes - but the problem is, it was not working anyway - I'll give it another shot tomorrow.
    But to me it looked (on the repetier image) like the menue is shown but with an overlay or whatever.
    Any developers that may help here?
  • edited October 30
    that´s the part which makes it work ,otherwise you just see the cursor if you did not modify the config.txt

    Sudo nano /usr/share/X11/xorg.conf.d/99-fbdev.conf 

    add following lines:

    Section "Device"
     Identifier "TFT"
     Driver "fbdev"
     Option "fbdev" "/dev/fb1"
    EndSection

    edit:

    i just did the 3 modifications i wrote here on a fresh image to confirm ;-)



  • Alright:

    I did it piece by piece & step by step acc. to the waveshare and your manual.
    So what do I have now, is a pointer that shows when I tap the display....and a display that shows...nothing.
    Only when the pointer is going around I see something. In addition the screen is upside-down (but the pointer goes normal).
    But still the screen is blank & black with a small cursor.

    I also installed lightdm, because after I switched on autologin, raspi-config recommends to install it in order to make the autologin work. (The wavshare manual mentioned to switch it on)
  • ok, so your display seems to be different from mine, sorry no more ideas from my side
  • Different approach: Any idea how I can make the GUI start on a system I've installed Reptier afterwards?
    And what about the Repetier-people? I mean I spent quite some money for the server, despite that there is Astroprint & Octoprint for free.
    So you could at least give some support!
  • Your problem is the xserver is not using the display. This is independent of repetier software. It is how the display you bought has to work with the xserver of linux. So it is configuration problem of the display. We do not own all displays nor do we write the drivers. The display producer should be the one telling you how to make it work in linux x display. I already tried to tell you how I had solved it for my display, but that seems not to work for you or it has changed with how x server or driver now works.

    It is not that I don't want, but it as not part of my product so I miss the required knowledge. You should try to ask waveshare how to make x server display on the screen. Maybe just some kernel parameter for the driver.
  • Thanks for the answer, I was guessing so.
    But...: When I use the readily made image-file, it boots to the desktop and seems to work well. Also I can set up Repetier, but what I can not, is to:
    1.) Start automatically (or just start it manually!) into the GUI of repetier.
    2.) How to change the port from 3344 to 80 (or 443 https).
    (When using your image, it is automatically on port 80 for the web-interface)
    Regards
  • Ok, so they have made an image where they did the required settings. So question is what is easier - find the setting for x server to display or copy all repetier stuff to the image.

    Port 80 is the nginx server we install. Read here
    https://www.repetier-server.com/webserver-access-repetier-server/
    how to setup yourself.

    The gui is just chromium which we have put into openbox autostart (the windowmanager we use)

    pi@FelixPi:~/.config/openbox $ cat autostart 

    # Uncomment the following 3 commands to have display always on

    #xset s off         # don't activate screensaver

    #xset -dpms         # disable DPMS (Energy Star) features.

    #xset s noblank     # don't blank the video device


    chromium-browser --noerrdialogs --disable-suggestions-service --disable-translate --disable-save-password-bubble --disable-session-crashed-bubble --disable-infobars --touch-events=enabled --disable-gesture-typing --kiosk http://127.0.0.1:3344/modules/front2/www/app.html


    So just install latest chromium on your image and check what is the autostart file so you can add that there as well. We have set autologin  in raspi-config so it starts completely.

    If that is all you need it would be fairly easy to copy.



Sign In or Register to comment.