Problems with connecting a Servo to am Mega Board with Ramps


I have some problems to connect a servo to am Ramps Board. 

I activate Servos in configuration.h and I activate the servo ui. I connect the servo signal to pin 11 on the board an the servo has an own power supply.

If I send M340 P0 S1000 R500 with Repetier Host the servo turns to max position and stays their. He does it all the time during I change the S-Value in the M-Code.

What is wrong with my Control 


  • What do you think is wrong with that behaviour?
    there is no "autoreturn". Servo moves to a position and stays there until you send a command where to go next
  • I think he means servo always stays at max no matter which position it is set to.

    What is the servo behaviour if it gets no signal at all? I mean move to center manually and add power with no signal. In your gcode you disable the signal after 500ms. Try S500 and S1500 which are the official extreme values. Should make at least a short move. If not use a multimeter to see if voltage on pin 11 changes or not. With S2500 i would expect 0.625V and at 500 it should be 0,125V.
  • That I cant contorl the position. Everey command I send in a range from S500 to S2500 the Servo turns to the max position. 

    The Servo dont move with no signal an still stays in the position which I put him by hand.  If I use the Servo Contorl UI or I send a M340 command the servo turns to the max position. 
  • edited October 2018
    as there are several ramps versions available just a question:
    on the left side of reset button(ramps board) there is a three pin header.
    is there a jumper located between VCC and 5V (the upper two pins) ?
    if not , there is no power supply to servo so it cannot move.
    !!!! if you mount a jumper the 5V is powered by arduinos 5V regulator which only can drive low current!!!!

    better way is to supply the middle pin by external 5V DC , dont forget to connect GND of external 5V Source to
    Ramps GND

    (that´s situation i have at my chinese Ramps board)
  • The same GND is the solution... Thank you for the great support. :-)
Sign In or Register to comment.