My extruder stepper motor will not work!!!

Hi all

I am new at this and am running a Rostock V2 printer, recently my extruder stepper motor jammed and stopped working. I ordered a new motor and installed it, BUT it still will not work. All other steppers (X Y and Z) work fine. I have tried switching the extruder stepper to the second plug (for dual extrusion) still will not work. The stepper does work since I tried it in my Z position and it functions.
Question is Software or Hardware? and what should I look at?

Thanks for any help


  • Did you test with hot extruder? Extruder will only move if it is hot or you have enabled cold extrusion (M302 S1).
  • You Sir are a Saint

    I have been pulling my hair out on this for weeks, various forums suggested it was the drivers/ the Arduino board etc. Now to find out it was this simple is a relief. I picked this Rostock up used having no experience in 3D printing whatsoever. It worked fine till the clog ad jam then it obviously was operator error.

    Thank you very much
Sign In or Register to comment.