Dual Motor Y-Axis homing problem

Hello Repetier-Forum

We have build a printer with a two motor y-axis and two endstops. I have selected the Ymin endstop to the Y1 motor and the Ymax endstop to the Y2 motor. When i start the homing command both motors home in the right way, but then they just start driving endless in the Y+ direction. We couldn`t find a solution jet. Can you help us?

https://www.youtube.com/watch?v=a43y68MpCZw&feature=youtu.be  This is a Video of the Homing procedure.

Thanks for your help.


  • It looks like y min homing worked without problem and then it goes away. 
    sets how far away from end stop it should move, so check what you have there. Normally you have 1-2mm so it untriggers the end stop, but not more.
  • I have already checkt this setting. I do not think thats the problem.
    I also think homing is working the rhigt way.

    Thanks for your help.

  • Yes, that is what I would expect. With that it should not do what it does.

    Do you have enough free memory reported in log when you connect to firmware? Sometimes low memory can cause very strange effects. 1kb free ram should be enough.
  • This is my log, i think it looks fine.
    I also downloaded the firmware again but it also did not change anything.
  • Ok, memory is enough available. That will not be the problem. If I understand you correctly all you have send is G28 Y0 to home y axis. the question now is if the homing did finish and the error happens afterwards or if it is part of the homing process.
    G28 Y0

    as a script so all gets send at once.(right click in manual control to edit them)

    M119 will report end stops after homing is finished. So if you see it never because you reseted the printer it is part of homing, if you see it after the move to front finishes it is something happening later.

    Depending on your homing order it is possible that it moves after homing to a home position. These are the one with preheat. Maybe that is the case here. These settings are not shown in screenshot.
  • I have always sent G28 Y0 to home the Y axis.

    I think the error happens in the homing command. I tried your script and i never saw the M119 command. 

    Where can i find the settings to the preheat home position?

  • Hey Repetier

    After i changed some settings in eeprom the problem dissapeared. I don't know what the ptoblem caused. But now it works.

    Thanks for your fast responds and your help.
Sign In or Register to comment.