Z-Probe - Preventing Nozzle from touching home point

I have a BLTouch Z-Probe which works great.  It homes at the exact center of my bed (100,100).  The probe goes to the center (100,100) and performs to probe function.  The way the BLTouch works, the actual print head is still above the print surface during the probing. But, after the probe is done, the printer moves the print head to the center and lowers it until Z=0.  The printer then raises itself and moves to (0,0,0).  So the sequence is Probe (100,100,0), Print Head (100,100,0), Print Head (0,0,0)

Having the print head move to (100,100,0) is an issue if there a little bit if filament oozing from the head. Now the printer has left a dab of filament exactly in the center of my homing point and the center of the printer.  How do I tell the printer not to move the print head to (100,100,0) but instead just use the probe?


  • Try setting ENDSTOP_Z_BACK_ON_HOME to 10 - this is added to the target height for the last height correction after probing. At least in current 1.x firmware version.
  • Thanks for the reply but it does not seem to work. ENDSTOP_Z_BACK_ON_HOME 10 does raise the head by 10 mm.  But it makes Z=0  10 mm above the build plate!  So the printer now print in mid-air.
  • You are right. You need ZHOME_HEAT_HEIGHT but that will only adjust z height in the end. So it might still drag to 0,0 at z=0 also I'm not sure about that.
Sign In or Register to comment.