Extruder stops during print (Repetier 1.0.2)

Hi to everyone,

i am new to this forum and hope there might be someone who can help. I already search the forum and found 2 entries related to my problem, but neither of those has any solution so far (besides the fact that the 2 entries are from 2015/2016, so quite old). The problem is, that the extruder stops during print (as described in the other 2 posts). I have no more ideas what could be the issue.

Printer is selfmade Core-XY, Arduino Due/RADDS, full graphics display (u8glib), Repetier 1.0.2. Everything works till suddenly the extruder stops mid print (not always, but in about 70% of the prints)

- No, it is not gone into dry run mode
- No, there is no entry in the logs
- No, no one of the temp-sensors get decoupled (no message in logs, not in display, they still show the correct temperatures, i also measured with infrared thermometer)
- No, driver and motor are ok (checked them on one of my other printers)
- No, the temperatures are not dropping or rising (well, within 1-2 degrees)
- No, i can not reproduce it since it seems to stop randomly (sometimes the same file prints till the end, sometimes stops randomly, could be at begin or mid or near the end)
- No, it doesn't matter if i print from SD, through serial or with repetier server (have a RPi3 with repetier server on this printer)
- No, slicer has no influence (tested Cura, Slic3r, Simplyfy3d)

The extruder just stops. It is still enabled, since i can NOT move it manually. All axis continue to move, there is no error in the logs, display is showing positions and temperatures as usual. But no filament flowing anymore. Just printing in and with air *gg*

This is so random, i get crazy. Tested sooo many things, but now i am done with my ideas. Cables, connectors, sensors, motors, drivers, mechanics, config settings, endstops... all was tested again and again and again (struggling with this issue for over 2 weeks now).

The parts i would think could fail (like autoleveling, using BLTouch as Z-Probe, G33) work without any issues. But the most important, printing, is not doing what i expect *grmpf*

Is there any more thing i can do other than switch to marlin? I like repetier, have it on my other 2 printers and there it is working flawlessly. The only difference is, the others have 8Bit boards (Rumba the first one, RAMPS/Mega the other).

Any help is apreciated. Thanks :-)


  • Actually there are only 2 reasons when extrusion motor gets not moved and that is cold extruder and dry run mode. There is a special case sending relative e coordinates in absolute mode but then motor jitters. You coverd quite well the typical reasons and if you are right there is only one left and that is a hardware issue. Thinks I might think of is drivers getting too hot. Normally this is only short and results in lost steps. Can you test when it happens if the motors are still powered? 

    What is required to get it working again? Can you just stop print and manually extruder or what do you need to do to make it extrude again?

    Another reason might be if it is blocked by a clogged extruder, but I guess you would have registered this.
  • Thanks repetier. Belive if or not, i have really no explanation for this, but now it works.

    What i have done is easy explained but not understandable for me. Instead of using configuration.h upload in repetier firmware configuration tool, i have gone trough all steps manually. After installing this firmware, it seems that the problem is gone (6h printing since then with no issue). Did i just got lucky or is this explainable?
  • Only if you have used different values or a different version it would be explainable. Entering manually exactly the same values for the same version should give the same result of course.
Sign In or Register to comment.