Bltouch Repetier Ramps 1.4 endstop not triggering

This is the most poorly documented thing i've wasted 40 bucks on. My meter senses output from the BLtouch and I've tried about everything I can think of but repetier/ramps 1.4 are not catching the signal..... Can anyone give me a straight answer?


  • Not even joking, I got mad and turned the endstop plug around, heard a pop and the lights dimmed on the board due to shorting it out. Turned it off swapped back and now it senses the signal? Maybe the pullup resistor was fried and now it can get the signal. IDC at this point I was about to throw it in the trash. Funny thing is i'm an avionics tech (no i wouldn't do it on an aircraft) but just damned exhausted with this POS when I know the signal is there and the software isn't picking it up.

    Note I do not consider this fixed, anyone with real information as to why I'm pulling my hair out please help.
  • As far as I know the signal is not permanent - only a short spike. So querying state with M119 will not work here. During z probe you even need a minimum speed as we only measure once per step for signals. So extremely slow moves might even miss the signal. I think you need at least 200 steps/s.
  • Yes, the signal is very short I believe 5-10ms, I haven't wrapped my head around the math behind how many steps there are per mm of movement but I had even tried 30mm/s movement on the z axis for probing and was not getting anything. I have to wonder if there was something wrong with my board that shorting the z endstop pins on the board to ground fixed/bypassed.

    In short I've tried I think all of the readily searchable solutions up to this point of frying my board with no luck. It's working now.... But IDK about repeatability of the process.
Sign In or Register to comment.