Problem with Z movement and homing

Hello everyone,

I have a cartesian printer with one stepper motor nema 17 in for each axis.
Both X and Y axis are working normally, but the Z axis is moving too slow.

I tried to change the resolution even though my calculated resolution is 400 steps/mm, and nothing changed.
I also tried changing other parameters as the speed and acceleration, but it always remains with the same problem.
When I turned the printer on and tried to move my Z axis, I saw that it was moving 1/5 of what it was showing on the display and it was very slow.

Also, when I tried to do the Z-homing, it should have gone from 0 to the maximum end-stop, but it didn't. It goes around 50mm and it inverts the direction to go another way without touching the end-stop.

I'm using the repetier-firmware configuration tool to make my firmwares, so I'm not a pro-programer and sadly I don't know how to change the parameters manually.

Someone have an idea of what do I have to do?


  • If you have a RAMPS board make sure the jumpers are installed under the driver boards. That might help.

  • Also note that after first upload many things like resolution and acceleration need to be change din eeprom. Use Repetier host/server which have an editor for this. Or use
    to copy changes in configuration.h to eeprom overwriting old values. Only uploading will not change this.
  • Thanks, that solved my problem. I had never changed my din eeprom since the first program sent. 
Sign In or Register to comment.