[CNC] Use Z_Probe G30 for cnc toolchange

Hello,

New in the doamine, I need your help.
I would like to run a laser tool detector on my machine.
Currently when I'm working on a piece with Estlcam and there is a change of tools, it's a hassle to remake a correct Z0.

I would like to use the laser detector to measure tool height automatically.

Here are the steps I am currently using:

Z height adjustment

 - G28
 - G1 X292 Y103 (Location the laser detector)
 - G30
 - G92 Z (Z_probe_height) This is done manually, I have not found a way to do this automatically.
 - G28
 - I position the axes on the top of my workpiece then G92. This is my work reference.

Until everything works. But when there is a tool change request I do:

- M401
- G28
- Tool change
- G1 X292 Y103
- G30
- G92 Z (G30 value)
- G28 Z
- M402
And not good, I find myself with the gap between tool A and B above or in my workpiece!

I know that the firmware is not really provided for this option but it seems to me that an automatic procedure (especially the G92 Z (n) after the G30) must be feasible.
Do you have an idea or another way of doing things?

Thank you in advance.

PS: I do not speak English, the text has been translated by Google.

Comments

  • You should use G30 like this

    - G30 H<height> R<offset> Make probe define new Z and z offset (R) at trigger point assuming z-probe measured an object of H height.

    That way no G92 is needed. And please do not G28 Z after that - it will loose your probed height as homing Z will reset Z position to homed Z position!

    My guess is that this is your main source of the problem.

  • edited August 2018
    Thanks for your help ! it works now.
    I put here my script for others:
    
    Placing Tool A:
    
    G28
    G1 X292 Y103 F15000 (Coordinates of the tool meter)
    G1 Z30 F6000 (I go down a little faster before the measurement to save time)
    G30 H-4.6 (The detector is below the 4.6mm bed)
    G1 Z60 F6000 (I go back so as not to touch the pieces)
    G28 Y
    G28 X
    
    Here the Z_min is now correct, I place my workpiece and move my axes to the starting point (top left of the piece)
    I'm doing a G92 X0 Y0 Z0 (I just realized that the G92 alone does not work) to put everything to 0
    I run the program Estlcam and when he asks tool B I do:
    
    M401
    G28
    G1 X292 Y103 F15000
    G30 H-4.6
    M402
    G92 X0 Y0 Z0
    
    and miracle ... everything works automatically! :-)
    
    It is also necessary to put a script in Estlcam in texts / change of tool:
    
    M05
    @pause (Change tool: <t> <n> <d>)
    M03 S <s>
    
    
    
    I do not know if Estlcam raises the tool before the break or not ... I have not yet had the time to try with a real program ... Otherwise it is necessary to provide a lift before changing the tool.
    
    Also, I noticed some anomalies with the indication of the coordinates displayed on Repetier Host after a G30 Hx,
    they do not match the LCD data and when I want to down Z with the software, it goes up to the stop before going down and I lose my steps.
    I do not have this problem if I move the axes with the CNC plugin for Repetier Host. I have not been to see further ...
    
    Thanks again for your help Repetier.
    You do a good job ;-)
Sign In or Register to comment.