Z Probe overriding Z min by M119?

I'm new here, until now I was just reading along without registration because I got everything answered trough old threads but now I got a problem:

I am currently changing my setup to mechanical abl. Therefore I want to home and probe towards z-min.
I already tried to find solutions but neither helped me out.

I'm using a Ramps 1.4 (with a custom extension board) and just want to use z-min pin (in this case 18) for both, so my ABL-Sensor is my Endstop.
So when I assign both towards 18 which is recommended everywhere, so the firmware knows Endstop=Sensor I get problems.
I evaluate the reading manually with M119 and the Sensor/Endstop once closed - once opened.
The reading never gets the Endstop High when the Sensor is assigned the same pin while the Sensor is getting the right result all the time.
When I assign the Sensor towards an other pin like 19 and insert a real endstop at 18 everything works fine and i get it right, but that's not my aim.
I already tried other pins without any sucess (so no crosstalk issue), tried to invert signals and tried all pullups and even software endstops.
So is there any override when it is assigned the same way, so the z-min Value is being neglected or am I missing something?

With kind regards Xolotl
Sign In or Register to comment.