sd card read error

Am having adruino mega 2560 and ramps 1.4 with reprap discount smart controller with repetier 0.92.9 firmware
sd card is detecting   and  files are showing when its connected over usb with the laptop just fine. 
but when i connect with the DC supply its not detecting the sd card but it says sd card inserted.
please help me out of this issue ....


  • Does it help to reset after powering directly? Then it could be a timing problem when power comes up too slow at the beginning. You could also test starting without sd card and then insert and see if it works.

    Apart from this there is no difference in code for the start methods.
  • thanks for the reply
    but its not doing the job
    .and also when i connect with dc supply laptop trackpad works weirdly 

  • Should not have any influence on other devices on the computer. But it is important that the board does not draw then 500mA with lcd etc. Normally no problem. USB and Arduino DC converter are only for that much specified.

    Is there anything else drawing much current like a servo (which should have it's own power and not use the 5V from board). No idea what else could cause such problems.
  • other than lcd and ramps 1.4 nothing else is connected with adruino
    but i have noticed that when i insert the sd card the lcd turns dim  both when connected via usb or  dc power.. 

    should i replace the ramps 1.4 or adruino or the  lcd , like which one should i replace 1st and check..
    please help me with this 
  • You mean it stays dim or dims just when you insert it? It dims if you get less current. You might try a different sd card first. Can not test here but do not remember that it dims for me.
  • yeah it stays dim when sd card is there inside 

    i tried different sd cards too but same result
  • solved .... removed the earthing wire from psu and now it works. i measured with a multimeter there a voltage difference about 0-3V flactuating from -ve to earth wire from psu.
Sign In or Register to comment.