How to change Z home position

I just flashed the firmware of my XYZ DaVinci 2.0a Duo with Repetier 0.92. It seems to be OK until I press Home Z then the bed moves too high. When I try to print the nozzle hits the side of the bed. If I go into the printer settings and drop the bed 2.5mm it looks to be the correct hight, but how do I save that as the home position?

I didn't know if I have to do it from the printer or my laptop, if from my laptop, then before or after uploading the firmware to my printer.

Thanks in advance


  • Does the da vinci use a regular endstop? min or max direction? For z min endstop you normally calibrate the endstop or bed to trigger exactly when bed is in contact with nozzle.

    #define ENDSTOP_Z_BACK_MOVE 2

    should be 0. You can set it to a value to go up afterwards, but it will then always hit and push the bed during homing, so better to adjust the endstop correctly.
  • Hi, thank you for the response. Sorry I've only just thought to look at this. I figured out that it actually needed to go down 2mm, not 2.5mm and I also figured out I could set and offset of 2mm on a print job so while it is still high, it drops down 2mm before printing making it the perfect height for the print.
  • Ok, so oppsite direction. This can be tricky if your z endstop triggers 2.5 above bed. First question is if you can still physically go deeper without damaging the sensor. Then you need to have disabled endstopcheck for normal moves and next you need to disable target position check I think with G1 S1 you do it. Then you could do it, but perfect solution is still to adjust endstop trigger point or make bed 2.5mm higher (some beds can do this).
Sign In or Register to comment.