Missing steps -> Where to start

Hi Repetier Community,

Coming from Marlin I used some sane defaults based on a known-good configuration but with repetier I get some missed steps/layer drift. I was wondering what would be the order of most-likely fixable firmware parameters? I see that there are many options that influence stepper control..
* disable quad stepping? Would that make it better or worse?
* reduce xy jerk? (But those values are known to work with Marlin...?)
* high and direction delay? 
* STEP_DOUBLER_FREQUENCY? Should it be lower or higher?
* DOUBLE_STEP_DELAY? The hint text specifically mentions that it should be increased when you experience missed steps? But by how much? should it be 0.1? Or 1? Or 100?
* Anything else?

Which one would you start with?
Thanks for any helpful suggestions!!


  • 1st i would make sure that always check endstops is disabled to eliminate any problems with cross talk on the endstop wires.


  • Thanks MartinH,
    Thanks for your tip. I checked and ALWAYS_CHECK_ENDSTOPS is already disabled.
    Do you have more ideas? My next idea is to reduce xy jerk.

  • DOUBLE_STEP_DELAY 1 is normally the value you want if 0 is not working. Some drivers want 1.8us so adding 1us to what it takes anyway helps if you have a DRVxxxx stepper driver. STEP_DOUBLER_FREQUENCY 12000 for 8 bit is ok and you can easily calculate how fast you move with your steps per mm and see if it needed at all or if you use it.

    Main error of old Marlin users is to check eeprom. We have much more in eeprom and first upload set it, so check if that contains the values you think you have set.
  • My DOUBLE_STEP_DELAY is currently at 0. I will try 1 and 2 soon. I have both polulu and drv drivers and I'll have to open the box to see which ones I eventually went with because I don't remember. I think they are the original polulu drivers because I didn't see print improvements and only more noise from the DRV's.

    The maximum speed in my slicer is 80 mm/s for travel moves. At 80 steps/mm that remains safely below the configured 12000 STEP_DOUBLER_FREQUENCY. This means that enabling/disabling quad stepping makes no difference at all at this point, correct? And the same for DOUBLE_STEP_DELAY?

    I have had some issues with the eeprom indeed so currently I have EEPROM_MODE 0/disabled. Am I correct to assume that even though there are values from previous uploads in the eeprom (in which eeprom_mode was 1 or 2) are not used at all by a firmware upload that has eeprom_mode=0?

  • Yes, at 80mm/s you are right but do not forget travel moves which are often faster.

    I named the wrong parameter btw.

    /** If your stepper needs a longer high signal then given, you can add a delay here.

    The delay is realized as a simple loop wasting time, which is not available for other

    computations. So make it as low as possible. For the most common drivers no delay is needed, as the

    included delay is already enough.


    #define STEPPER_HIGH_DELAY 0

    Is what makes slow drivers detect the signals. DOUBLE_STEP_DELAY is for the low signal between the double steps, but if you stay below 140 any double stepping is not relevant anyway.
Sign In or Register to comment.