Z axis doesn't move after G32 S2


I'm using fw 1.0.1 and a week ago it was working fine. But a few days ago, when I tried to print, the command G1 Z0 is "ignored" after G32 S2.

All axes moving normally, but just after G32 S2 the Z axis does not move until I move the X or Y axis.  

I'm using Z-probe as z-min endstop with servo motor.

I replaced the cables of motors, endstop and the servo but the problem persist.

I've seen the logs on the repetier host but there are no errors after G32 S2.

Can someone help me, please!?


  • What does M114 say after G32 S2? Also check M119 if z min is triggered as you can not move down with endstop triggers in some configurations. Same for Z - you can not go below z min. So if z probe height is not configured correct this might be assumed as z min.

     You know S2 is only there to store result to eeprom, so you do not need to do it again and just home Z instead?
  • M114:
    X:147.01 Y:150.0 Z:39.338 E:0.0000
    (Z:39 is the Z position with servo arm up)

    All in low state

    After G32 I can not move Z up and down. Right after the X or Y movement, the Z axis returns to move

    Sorry about S2, I modificated my 3D printer and kept the "S2" in factory start script. It always works fine with the G32 in the start script, but a few days ago it stopped
  • Very strange. Looks normal except not moving. Question is what changed a few days ago when it started happening. Anything changed? New firmware, eeprom changed, ... 
  • Nothing changed. I tried to use a backup of eeprom, I loaded the firmware, but this continues.

    I will try upgrade to 1.0.2
Sign In or Register to comment.