SHARED_EXTRUDER_HEATER = 1 not affecting temperature reading?

I am struggling to setup a Y-Style dual extrusion hotend with a shared heater but two extruders (obviously) ...

I have set 


I dont want it to be a mixing extruder, since I am not using a Diamond Hotend or sorts, so it should be toolchange with full retract codes and stuff. So originally when generating the Firmware MIXING_EXTRUDER is set to 1 which then seems to prevent it to be shown in the LCD in the first place as an additional extruder? 

When I set it like above, I do get to select between extruders, and if I select extruder 2 and then try to heat it up, it actually heats up the hotend, but fails to report the temperature as you can see here in my RADDS LCD:

Even though the heater and also the hotend fan seem to work fine for extruder 2, the lack of temperature reporting seems to prevent me actually moving the extruder, presumably because it is considered cold and I have that setting to the default of 100...

Here is another shot of the repetier-server touch interface, where you can see that the setpoint temperature being relayed correctly to the second extruder "PP" but not the actual temperature:

I could probably fix this by matching the TEMP PIN of ext 2 to ext 1, but isn't the SHARED_EXTRUDER_HEATER supposed to do just that?


  • You need

    so the second extruder reads same temperatures. SHARED_EXTRUDER_HEATER is really just using the same heater so it does not mix 2 devices turning it on/off but current temperature needs just the same input pin again. It is just for reporting temperature and has no internal effect.

  • Wow that was fast :)

    what about

    should I set that one to HEATER_0_PIN too?

    would be brilliant if the config tool could handle these things though :) but I guess you are busy with 2.0 right now...
  • Heater pin for ext1 is not used and could be set to not connected (-1) to mark it clearly. Also to prvent it gets initialized.
  • edited May 2018
    just for completeness sake; 
    #define EXT1_TEMPSENSOR_TYPE x
    should also be matched of course...

    works fine with these settings! Thank you for your superb support!
Sign In or Register to comment.