E3D Cyclops configuration in 1.0.2

So I set up my Cyclops 2 in/1 out extruder as detailed over on the E3D wiki, selecting Mixing extruder, etc in the online configurator. I noticed that the configuration options for my second extruder motor just disappear, leaving me only the ability to choose 'Extruder Stepper', 'Invert motor direction', 'Invert enable signal' and 'Enable mirroring'. Since I was already under the hood, I also changed my extruders to Titans. 
Having done this, I found that I don't seem to be able to test extrude from individual extruders. They're both extruding at once. In addition, I adjusted the steps/mm for the new extruder, but it appears that only Extruder 0 got the message to make the change. Am I missing something glaringly obvious? I don't mind ignorance if someone can help me correct it.

Thanks in advance.

Comments

  • Depend a bit if it is a mixing extruder or just 2 extruders with shared heater. Both are supported but work differently.

    For mixing extruder you set mixing ratios in eeprom which are set now to 50/50 so both move at once. Setting them 100/0 and 0/100 would make it move only once.

    If they should not reall ymix just use shared nozzle it is better to not select mixing extruder but instead say they have a shared heater and treat them as 2 individual extruders.
  • edited April 29
    Thank you. I see why it was acting the way it was now. Since the Cyclops isn't a true 'mixing' extruder, I think this is where my problem is coming in. I'll deselect 'mixing extruder' and reflash. That should fix the issue. I'll also pass on the information to the folks who maintain the E3D wiki.
  • Ok, just make sure to set the shared heater flag as well.
Sign In or Register to comment.