How do I set up repetier firmware to know my bed is 27 mm away from my x limit switch?

How do I set up Repetier firmware to know my bed is 27 mm away from my x limit switch? I'm running version 0.91

Comments

  • Depend on what you want. Do you want the reagion be reachable, then set xmin to -27. Do you want also to start at 0 above bed then set "Endstop distance after homing ENDSTOP_(X|Y|Z)_BACK_ON_HOME" in config tool or configuration to 27.
  • I just tried that.  After I home my x axis the nozzle ends up 10 mm over the bed.  It goes to the left then once it homes 2 times it goes about 40 mm to the right.  I want the nozzle to be 10 mm further to the left after homing so it is just on the edge of the bed.  I set #define X_MIN_POS -10 and #define ENDSTOP_X_BACK_ON_HOME 10 and the nozzle is in the exact same place but the position in firmware says -10 now. When I set X_MIN_POS 10 then the position is correct but it will not go left to 0 no matter what I set ENDSTOP_X_BACK_ON_HOME to.  I know this has to be a newb thing and once I see it I'll end up face palming myself, but I just don't see it yet.  Any help?
  • Just tried experimenting with several settings.  I set #define ENDSTOP_X_BACK_ON_HOME 20 and the nozzle is now 30 mm to the right of the left edge of the print area.  I set #define ENDSTOP_X_BACK_ON_HOME -40 and  it just goes back to the usual spot instead of 10 mm to the left of the left print edge.  I would expect it to move 20 mm to the left of where it is now, but instead of being 40 mm to the left of the previous location (when it was at back on home was 20) it only moved back 20 mm to where the nozzle is 10 mm to the right of the left print edge.

    My #2 extruder is about 35 mm to the right of the #1 extruder.  Could this be the issue?  If it goes any further left, the #2 nozzle could not print without hitting the x home switch?
  • Ok you omitted the essential data of having 2 extruders. At left position you must be able to activate both, which means that with left extruder active you need to be able to go 35mm to the left to activate second extruder at same position. So with extruder left active homing MUST have at least 35mm gap to endstop switch.
  • edited May 1
    lol as I said in my first post, facepalm >_<.  I'm learning that these 4 extruders in a square pattern make this setup a lot more complicated than I'm used to and a bit harder to troubleshoot.  I just have to make my bed shorter and make sure all extruders stay within the print space.  I only lose about 10-15 mm print area on each side.  But on the bright side, I'm able to print from it from it now and once I get bed leveling working on this 300x300 bed, I'll be a happy man :smiley:
Sign In or Register to comment.