Crash in preview when right-clicking

Steps to reproduce:

- Download

- Load it in RepHost

- Slice it (tested with slic3r 1.1.7 that is bundled with RepHost 1.0.6 and slic3r 1.2.6 64-bit)

- In the preview, once the object is sliced and rendered, right-click to crash RepHost

OS is Windows 64 SP1, 64-bit

If there is anything else I can provide, please let me know.



  • Sorry, could not reproduce it on Win 7 64 Bit.

    1. Where did you right click? 

    2. Does this happen with each preview? Does it happen also if you select preview tab without anything loaded.

    3. What does the crash say. Especially if you can open details the stacktrace might be a help.

    BTW: Rightclicking in preview has no function. Object move is only in object placement possible.
  • 1. Happens anywhere in the preview window

    2a. No, I noticed this problem with two objects so far. Smaller or less complicated ones don´t show this problem (tested with about 5 others).
    2b. No

    3. I can only see these details (in German):
    Problemereignisname: APPCRASH
    Anwendungsname: RepetierHost.exe
    Anwendungszeitstempel: 548b0e64
    Fehlermodulname: ig7icd64.dll
    Fehlermodulzeitstempel: 506351d0
    Ausnahmecode: c0000005
    Ausnahmeoffset: 00000000000893de
    Betriebsystemversion: 6.1.7601.
    Gebietsschema-ID: 1031
    Zusatzinformation 1: 6911
    Zusatzinformation 2: 69119e45ce63a2ca5406fa24223111b2
    Zusatzinformation 3: 61c0
    Zusatzinformation 4: 61c00360a32e102de16ffd5740162814

    Should I find more information anywhere else?

    4. I know, but using three different programs (FreeCAD, MeshMixer, RepHost) that use three different ways to navigate the 3D view leads to this =/

  • Germin is ok:-)

    It is a crash in the intel graphic driver. Not htat I'm surprised it is a intel card - seems what ever the problem is only affects intel cards:-( 

    Since it happens only with bigger objects, could it be a memory issure with graphic card memory exhausted? What level of detail are you using for gcode preview? Don't go higher then medium especially with bigger models.

    If you select single layer preview, does it still happen with that object? Would need to go through all layers to test if one layer has a visualization error that causes the crash since we ruled out memory problems with only showing a single layer. If it is a single layer, please send the gcode and tell me the layer that crashes, maybe I can then find a error in visualization algorithm.

  • 1. memory issure: I´m using a laptop with Intel HD Graphics 4000, so I can´t exactly tell how much RAM is used for that. Laptop has 8 GB in total.

    2. level of detail: In preferences, "Draw Method" is set to "Autodetect Best". From the log "Using fast VBOs for rendering is possible". Crashes when using "VBOs ( Fastest)" directly. Still crashes when using "Arrays (Medium)", and NO crash when using "Immediate (Slow)".

    3. layer:
    Layer 1: no
    Layers 0-42: no
    Layers 0-43: crash
    Layer 43: no
    Layers 42-43: no
    Layers 42-67: no
    Layers 10-43: no
    Layers 10-53: no
    Layers 10-67: no
    Layers 0-43: crash

    md5sum: 439ae631fe27d7694e39737243f06a9e
  • Did you already have time to check this?
  • No not yet. Hoped for a 1 layer error. Unfortunately the file is not downloadable (any more). Get redirected to startpage of filedropper. Did not know they delete so fast. Maybe you could reupload it.

  • Yes, indeed. Didn´t use this before, but I have now reuploaded. URL is the same as before.
  • Ok, download worked. Viewing with non intal card i sno problem (have no other). Will use it to test some plausibility tests as I guess the buffers get some data that intel driver do not like. Maybe non-exting vertex indices or degenerated triangles. Hope to find something like that, which would explain the problems.
  • Thx, will be glad to test a new version or help debugging if possible.
  • Please check your messages in forum. I have send you a link for testversion that hopefully works better.
  • Tested with 1.1.0, still crashes.
  • Today my repetier laptop did a windows update (has not seen the internet for 2 years) and I ran into the same problem. I fixed this by updating the graphics driver from Intel themselves, not from microsoft.
  • You mean there are 2 possible drivers for intel graphic cards? If that is true that my explain why some users with intel cards have problems and most don't. Could be a important information.
  • Thx, atunguyd! Updating the drivers fixed the problem.



    Versions according to Speccy. Version according to Intel website and package:

Sign In or Register to comment.