All motors energized but not moving at all

edited April 2018 in Motor Control
I am currently building my own 3D printer, a CoreXY system, with the latest Repetier firmware. RUMBA board and DRV8825 drivers.

The heating of the extruder works, the heat bed works via SSR, the end stops (tested with the M119 command), the temperature sensors, the fans (currently disabled in FW), the display works. This all works.

ONLY the motors do NOT move. No matter what I do, I can't make the motors spin. The motors are energized, so they have power. You even cannot turn the spindle by hand! But the motors are not turning at all. All axis and extruder motors are affected. I tested the motors without any load, so not mounted to anything.

What I've tried so far:
- the microsteps are set (to 32)
- the driver voltage is set (to about 0.60 V)
- tried different driver modules
- tried different stepper motors (all of them "ordinary" Nema17 steppers)
- the correct phases and connections of the motors have been determined (I've also read the motor data sheets)
- the enable signal in the repeater firmware has been inverted and back again

None of this works. I'm at my wits' end.

I would be very happy if someone could help me.


  • Here's my FW configuration:
    (external image because of size)
  • I thought maybe move only when homed, but that is not set in your config. If the get power so they block motor connection should be ok. So all you say is step signals do not come through. Unlikely that this is a hardware failure on all sockets. 

    Does disabling motor (M84) make them moveable again? Just a check that orientation is ok, also I guess otherwise the motors would not have blocked at all.
  • edited April 2018
    possibly reduce your steps/mm. I would try about 1/2 of # of steps setting or even lower just to see if they will move.
  • Roko, thanks for your answer. Unfortunately, no luck with lowering the steps/mm. I set them to 200 steps/mm for each stepper motor, but that didn't work.

    Repetier, thank you, too. M84 did not change anything. Motors are still on and energized after sending that command.

    BUT I had a very little success after altering the firmware settings a bit. I changed these settings (beside of the lower steps/mm):

    - "EEPROM usage" to EEPROM disabled (before it was EEPROM set 1)
    - "Delay stepper high signal" to 2 (instead of 1)
    - I also disabled all fan pins since I control my fans externally.

    Now, the command M84 seems to work. It switches the motors off. After attempting to move the motors (in Repetier Host with manual controls) the motors get energized, again. BUT also again: still no movement, no rotation!

    Do you know what else I can try out, maybe altering other FW settings?

    If nothing works I guess my RUMBA board is broken somehow. :( Oh my luck with electronics...
  • M119 shows H when endstops activated ?
    could you post the actual configuration.h that was used to load to the board? (In case something got d/l'd wrong)(just a thought)
  • can you post a pic of your rumba board with drivers fitted.
  • Yep if the drivers are oriented incorrectly they will not work.
  • @Roko: Yes, M119 returns a "H" when an endstop is activated. The endstops seem to work flawlessly.

    The configuration.h of the current version of my firmware can be found here:

    @MartinH: Sure, but I'm afraid that doesn't mean too much since drivers of even the same model can have different pcb layouts. I only made sure to connect certains pins of the DRV8825 drivers to the corresponding pins of the Rumba board. For example, GND is in the lower right-hand corner (as I recall correctly), therefore the poti is at the top of the driver.

    Moreover, here's the spec sheet of one of my Nema17 motors:

    As you can see, the cables of the motors are in the same sequence as demanded by the Rumba board: Black, Green, Red, Blue. But as already said I also tested different combinations of the cables.

    The displays returns some ??? for the state of the motors. What does that mean?

  • edited April 2018
    Ok, problem's finaly solved. Thread can be closed now. :smile:
  • what was it?

  • It was the drivers. All dead-on-arrival. No joke. I couldn't believe the whole batch that I ordered was broken.
  • I've got similar problem. Rumba+ board, DRV8825 step drivers, no motion control. This board has previously worked with same drivers, but recently reflashed it with RF to replace burnt out controller in my delta. Have also tried A4988 drivers from previous (MKS Gen L) board as well, but motors will not work (also NEMA17s that all worked previously).

    I've tried different combos of microstepping, but need a sanity check on FW settings:
    Configuration.h motion settings
    #define DRIVE_SYSTEM 3
    #define XAXIS_STEPS_PER_MM 80
    #define YAXIS_STEPS_PER_MM 80
    #define ZAXIS_STEPS_PER_MM 80
    #define EXT0_STEPS_PER_MM 100
    #define EXT0_DIR_PIN ORIG_E0_DIR_PIN
    #define EXT0_INVERSE 0
    #define EXT0_ENABLE_ON 1N
    #define EXT0_MAX_FEEDRATE 50
    #define EXT0_MAX_START_FEEDRATE 20
    #define EXT0_MAX_ACCELERATION 5000
    // ################# XYZ movements ####################define X_ENABLE_ON 1#define Y_ENABLE_ON 1#define Z_ENABLE_ON 1#define DISABLE_X 0#define DISABLE_Y 0#define DISABLE_Z 0#define DISABLE_E 1#define INVERT_X_DIR 0#define INVERT_X2_DIR 0#define INVERT_Y_DIR 0#define INVERT_Y2_DIR 0#define INVERT_Z_DIR 0#define INVERT_Z2_DIR 0#define INVERT_Z3_DIR 0#define INVERT_Z4_DIR 0#define X_HOME_DIR 1#define Y_HOME_DIR 1#define Z_HOME_DIR 1#define X_MAX_LENGTH 200#define Y_MAX_LENGTH 200#define Z_MAX_LENGTH 602.725
    #define MAX_FEEDRATE_X 100
    #define MAX_FEEDRATE_Y 100
    #define MAX_FEEDRATE_Z 100
    #define HOMING_FEEDRATE_X 40
    #define HOMING_FEEDRATE_Y 40
    #define HOMING_FEEDRATE_Z 40
    #define STEPPER_HIGH_DELAY 0
    #define DIRECTION_DELAY 0
    #define STEP_DOUBLER_FREQUENCY 12000
    #define DOUBLE_STEP_DELAY 1 // time in microseconds
    #define MAX_JERK 20
    #define MAX_ZJERK 0.3
    #define MOVE_CACHE_LOW 10
    #define LOW_TICKS_PER_MOVE 250000

Sign In or Register to comment.