Auto Correction

I have a cartesian printer using a Due with RADDS.  I am using auto leveling command G32 S1.  I home at Z Max.  When I run the auto correction everything seems to work fine, transformation matrix is calculated and I get a good level plane on bed.  However when I attempt to home all axis again, Z and Y work fine but X homes and when it completes it moves negative back into the X limit. Acts like an X offset is being applied.  This only happens after I auto correct. Homing works fine prior to Auto Correction.  This behavior with X is the same whether I use a G28 or homing button in Repetier Host.  Any thoughts?


  • It might be that it corrects the rotation, so if bed goes up to the right that means x=0 at the top is more to the left.
    You can tell host to add extra distance from endstops. In fact for Z you even must do this and for xy only if rotation and endstop requires this.
  • Thanks.  Makes sense.  My bed is leaning up to the right.  I can level it but I thought I would take the easy way with the probe.  What command do I use to add distance to end stops?  G132?  
  • No command. It is a configuration option where you define the homing and endstops in config tool.
Sign In or Register to comment.