Out of Video memory / Exception while drawing

Although the printer keeps on printing the text "Out of Video memory / Exception while drawing" pop's up now and then. The remedy is to wait until the printjob is completed and close and restart the program.

During this screen I still can switch to other screens, like looking at the temperature curve or any other tab. As I am running Repertier Host  (V1.04) on a laptop with Win 8.1 and huge amount of memory, system constrain's cannot be the reason.


  • Any Idea what might cause this behavior?
  • That error should happen only if we get an exception from the drawing routines caused by graphic driver. Limiting factor here is not your normal memory but the video memory. Especially if you have good filament fisualization quality the ram needed can be quite high. Since 1.0.4 we write additional informations to the log about the reason and position why this message was triggered. What do you get there? And does this also happen for smaller objects?
  • Yes, that is what I would expect. However I was not able to find any log-file, at least not in any of the repertier-directories. Please direct me were to find it.

    The problem may be related to the size of the object, at least it only shows-up (but not always!) after considerable printing-time (30minutes or so), not easy to reproduce!

    I doubt if it really has to do with lack of video-memory, I am using an additional screen next to my laptop, disconnecting this screen, and thus not using that additional gaphical memory does not seem to make any difference.


    Thanks for your answers and great software!


  • Log is inside host. Disbale easy mode then hit "toggle log". You can also enable logging to file in Prefrences->Genral settings and after a restart it logs to repetier.log in the work directory.
  • Ok, so obvious I did'nt see...

    The log say's :
    17:00:44.232 : Error drawing 3d view:Poging tot het lezen of schrijven van beveiligd geheugen. Dit duidt er vaak op dat ander geheugen is beschadigd. /    bij OpenTK.Graphics.OpenGL.GL.DrawElements[T3](BeginMode mode, Int32 count, DrawElementsType type, T3[] indices)
       bij RepetierHost.model.GCodeVisual.drawSegment(GCodePath path)
       bij RepetierHost.model.GCodeVisual.Paint(I3DView view)
       bij RepetierHost.view.ThreeDControl.DrawModels()
       bij RepetierHost.view.ThreeDControl.gl_Paint(Object sender, PaintEventArgs e)

    This error does not affect printing, just the screen is no longer showing the progress. Actually, while I am typing this the printer continues to print. Hope this helps to make the software even better.

  • Just updated to version 1.0.5...
    The same problem occurred about half-way printing the object (layer 86 of 162)
  • Now updated to version 1.0.6 and did 2 huge prints for a total of 5 hours printingtime, no problems anymore!
    I am very happy with this update!
  • I had this problem when using Repetier Host on my old laptop (IBM Lenovo X61 with an Intel graphic card). I've solved it by reducing the color depth from 32 bit to 16 bit while keeping the maximum screen resolution allowed (1024 x 768). Now everything seems to work properly. Many thanks for this useful software!
  • I also had this same problem with Lenovo T61, and the same downgrading (32bit --> 16 bit) worked with me, too!
    Thanks for hint!!
Sign In or Register to comment.