Homing puts Z through max value

Hi all,

my repetier version can be found here: https://github.com/Anteino/Repetier-Firmware/tree/500XL-Minimal

I implemented a wizard to calibrate the extruder offsets because it's not possible to do this physically (I use a hall sensor that can not easily be adjusted). I think this might be part of the reason that's causing the following problem.

I have my printer home at it's max Z position. All is fine and dandy until I enable FEATURE_AUTOLEVEL. When I set this to true, the printer goes through its maximum position. The max Z length is 500 mm. The offsets of both nozzles are about 2 +- 0.05 mm. With FEATURE_AUTOLEVEL set to false, the printer moves to Z = 498 after homing for obvious reasons. But when I enable FEATURE_AUTOLEVEL again, the printer moves to 502.71 after homing causing the printer to move through its boundaries and hurting itself. I figured out that this is not caused by Printer::homeZAxis(), but I can't seem to figure out what's causing this error.

Please help :/ If you need the contents of my EEPROM I can post them here.


  • Check bed coating in eeprom. That value will make z move after homing. Also with z homing you should also have

    #define ENDSTOP_Z_BACK_ON_HOME 2

    to allow some back move to adjust to tool offset or different bed coatings or rotation measured. In fact it could be the rotation if the rotation matrix is not 0 it might cause an additional offset. So also reset rotation  matrix for first tests.
Sign In or Register to comment.