Second extruder 10 degrees to cold

edited March 2015 in Extruder & Bed

I have the dual version of the Felix V3
The first extruder heats up normal and hits its temp just fine
The second one heats up normal but stops 10 degrees below the set temperature
tried to autotune the PID of the second extruder but with no positive out come
Tried switching the hot ends but the problem remains
It makes no differents if i set it by software or set it using the display


  • That problem seems to be fixed with latest 0.92.2 firmware. Just update.
  • Thx i installed the new version
    The second extruder heats up to the set tempatur but then starts to jump around.
    Going between 230 to 198 in less then a second and back in less then a second.
    With a older version of the firmware i have only the problem that the second extruder won't heat up to the set temp.
    Just to be sure i connected ext1 to the connectors of ext2 but the problem remains
  • Physically it is impossible to get such fast jumps. So question is what causes the jumps. Did you change heater to use PDM instead of PWM causing some kind of crosstalk to sensors when in hold range.

    Do both extruders jump so wildly or only one?
  • I only have this problem with extruder 2

  • Have you checked if thermistor for extruder 2 has still good contact. Bad contact can cause wild jumping values or crosstalk can have a simlar effect. As a test heat up and disable all heaters and motors. If jumping stops it is crosstalk. If it still jumps it micgt be a loose thermistor.
  • I have also had this issue with 92.3 but with single hotend, ramps 1.4. Basicly it blip the temp sensor about 10-15c for 1-2 seconds intermittently. On long prints it will sometimes freeze the extruder motor but continue to supply current to the motor. I admit I have modded the firmware by adding jkn advance and fixed the eeprom bug reading the auto retract setting but I have been using 92.2 with same mods and no issues. I even replaced my thermistor connectors and wires thinking it was a hardware issue (sent a few days going through everything looking for an issue). I just flash back to 92.2 (same mods) and running with a perfectly flat temp reading and no extruder freezes yet.
  • I see I have forgotten to update the thread. There was in deed a bug in the extruder switch routine when using PID. That caused the 10°C drop. After fixing it Felix printers had no problems with this issue any more, so if you still have it you are missing that update.

Sign In or Register to comment.