Repetier Host v. 2.0.5 Initialization Loop


I have updated my Lulzbot TAZ5 firmware to Marlin

Repetier Host (v.2.0.5) cannot connect to printer properly. It remains in initialization loop and stops never.

"Printer reset detected - initalizing"
. . .
"Printer reset detected - initalizing"
. . .

Any help? Thanks!


  • Host does not reconnect so this must be the firmware restarting all the time. Did it work before you updated firmware?
  • Yes, it worked before firmware update. And Repetier Server works with the new firmware. Only Repetier Host has problem. I would like to use Repetier Host because it has so handy one click manual movement buttons (1, 10, 50,...) Temperature, speed and other controls are better in Repetier Host too.
  • You can use server and connect to it with host. In connection in host there is a server connector. That way you can also close host and print continues.

    Lately printers seem to get picky about where they work. Both do more or less the same thing on connect so I wonder why this makes a difference. What does the log say is the restart reason using host? Normally firmwares tell this on startup, e.g. watchdog, reset, brownout.
  • edited February 2018
    I tried server connection but the same problem remains in the Repetier Host. I attached both server.log and repetier.log.

    Edit: Seems that I failed to attach log files. Here is link
  • Seeing the log my impression is that reporting sd card content causes the restart of firmware. Unfortunately no indication of restart reason from firmware.

    What happens if you remove sd card and then connect? 

    My guess is that this is the problem and since server does not use sd cards it does not try to read them on connect.
  • Removing the sd card solved the problem! Thank you for your help!
  • Good to know. So that make sit sound like firmware likes to crash. Maybe just something on sd card that makes this happen.
Sign In or Register to comment.