Why would all completed jobs show failed in repetier-server?

I do have an execute command to shut off printer but it is after the job is done.  Does this have something to do w/ the buffer not being completely cleared before shutting down?  Each of these jobs (Some duplicated) completed successfully.


  • Yes, I guess it is the disconnect of printer before handling is finished that makes them wail.
    You could try adding a 
    sleep 10
    in your shutdown script to give server time to finish regular close.
  • edited January 2018
    Where to add that (top or bottom)?  I did add a wait command for 5 minutes before the 1ms waits.  How does sleep 10 differ than the dwell commands already in place?
  • edited January 2018
    Just created a simple one line print w/o any of the wait commands and it also shows failed.  Repetier-informer says job finished so I have no idea why the time-lapse says failed.  Sometimes I get a good time-lapse others I just get the  initial shot and nothing after.   During the print it states capturing and it does show the camera output properly while printing.   Under time-lapse For FFMPEG path I have /home/pi/ffmpeg although I am using mjpg-streamer (if that matters).  Also all times for these recordings also show Universal time instead of local time just like repetier-informer does.  I look in /var/lib/Repetier-Server/$Printername/timelapse and the images are there.
  • If this helps, here is the server.log for this print as well as the gcode I used (all prints see to do this however).  I had to zip it as I could not attach the gcode properly.  Same deal here Short 1 layer code w/ nothing other than the stock cura end gcode.  .Results in fail in finished timelapse videos.   Will repetier server purge these captures over time or at a certain size?  I do see it won't run when there is less than 500mb free.
  • I meant the sleep 10 in the disable command you call. SO not inside server. You must ensure the printer gets disabled after print has finished.
  • edited January 2018
    Either way I disabled my power off command as you can see by the attached Test gcode and it still says 0 failed for every single video
  • uups. Did not see it was videos. Thought it was the history.

    If you click on the eye what do you see? There you see more details and also if images are there. I guess the failed means conversion to mp4 failed and that normally means you have no ffmpeg installed or configured in global settings.
  • edited February 2018
    If I click the eye I see the time lapse of the video sixth plays properly. I do have ffmpeg installed but unsure if it's configured properly. I did provide the correct path in global | time lapse but that's as far as I went, is there more config to be done?
  • There are 2 players for videos. One goes simply through the stored images and you can go image by image. The other plays the rendered video. So i guess it is the first you see. There should be a error reason when you try to render the video. You can restart rendering.

    Setting correct path to ffmpeg executable is all that should be needed.
  • I do have the correct path /home/pi/ffmpeg (As far as I know it's the only ffmpeg dir) so I don't know what is going on.  With that said I noticed that while i see the camera (Dynamic image URL) and still shot (Static image) in printer settings in server I have a generic camera icon under printer settings | webcam | video.  Could this be part of the issue?  I'm going to try to do some testing of ffmpeg and see if I can find some login that may point me in the right direction.
  • Solved.  After doing some research it seems there are issues w/ ffmpeg and Jessie.  pointing to   /usr/bin/avconv fixed the issue.  Thanks for the help.  So now the only issues unsolved are the cropping of webcam which you are aware of as well as the UTC instead of local time.  One more question.  Any way to order the Finished timelapse videos with most recent on top instead of having to scroll 2 pages down to get to the most recent?  Also, do these delete at some point to preserve space or does it just recording when there is less than 500mb of space available?  
  • Cropping is solved for next host version. Already found that. Use toolbar webcam until then. UTC is also solved.
    Sorting is not possible and you have to delete yourself from time to time. When space runs out timelapse will not start recording.
Sign In or Register to comment.