Messy layers 2-4 then a perfect print. WHY???

ok, I'm a bit frustrated here maybe somebody can help me out. I have a large delta 3D printer that's been up and printing for over a year now. Yesterday I re-did the heating element under the bed so now I can heat up the 460mm dia. Aluminum bed to 60 deg. in around 6 minutes. Now I get a really weird print problem. I'm printing directly to aluminum with 70 starting temp then 60 for following layers.

I get good bed adhesion and a perfect layer 1 and 2 then the layers get messy. I have set  up the print to do a .5mm z lift with every retract. In the layers 3-5, it seems to lift about 5mm and does not come down all the way. So what I get is a nice flat bottom. Then a few layers of under extruded mess where it seems to be printing at about .5mm+ layer height then after that it goes back to normal and prints the rest of the part perfectly. I have used a different slicer profile, I have tried re-doing z-leveling with ( I have a probe) I have killed everything and re-booted both the printer and the arduino+Ramps. I have tried three different .stl objects, I even re-uploaded my arduino firmware. ... what the heck.

I am using ramps with repetier. Not sure what other information is useful because everything worked perfectly.

The bed is driven by a 16V AC transformer and a DIY 25A solid state relay. When heating up the bed draws 26A. The heat sink stays in the not too hot to touch rang then cools off very quickly once heat is off.



  • edited January 2018

  • edited January 2018
    The final 20x20x20 cube also has a 22mm height. Something is for sure of with the height of those few layers.

    I'm not sure if this is related or not, but I have also noticed that even though I have calibrated my extruder pretty closely within 2 mm. I still have to reduce flow rate down to 89% to get a decent print. Otherwise I see obvious over extrusion problems.
  • If it does not come down all the way with z lift that of course gives messy layers. Being 2mm higher then expected also indicates that this did not happen. So questions is why would this fail. Normally loosing steps because I think the printer would show 20mm at top. Can happen if you come down on hard parts that are higher then expected and already cooled enough or acceleration/speed too high for the problem.
  • If the problem were throughout the part it would indicate that the parts are cooled down to much. But what I observe with z-lift going at least 4mm higher than on other layers in this area indicates something different. My best guess is that it has something to do with bed leveling compensation. I have bed leveling on and somehow the algorithm for those first few layers is wrong? I don't know. I'm pretty sure it's not because of lost steps. If it were lost simply lost steps, then I should see less z lift not more on these layers.
  • I'm guessing I need to completely reset and start from scratch. I thought I was doing that by re-uploading the firmware, then re-doing bed leveling, but either the problem re-occurred or I didn't properly reset everything.
  • Ok. I got it resolved by re-uploading firmware with eeprom_enable set to 1 then re-doing z calibration and bed leveling. I though I was doing thing before, but eeprom_enable was set to 2 for some reason. That didn't reset everything as it should have.

    I'm glad to be back to printing :)
  • it seems i spoke too soon about having it resolved. I still have the problem but to a lesser extent. I still think it's related to distortion correction somehow, but the effect is much less prominent now that I re-did everything. Any ideas how to get rid of this or confirm my theory?
  • The finished product is pretty square though. So it was under extruding those layers.
  • you could try disabling distortion correction, manually level bed as best you can and see if layers are seperated though the print might not be as good on 1st layer.
  • Ok. Today I tried turning off auto leveling with M323 S0 and re-doing that calibration piece. You couldn't really tell the difference. It was the same. So I manually worked at adjusting the physical leveling of the bed. I got it a lot closer than it was. Then I re-calibrated and tried again. I saw a lot of improvement in my 20mm cube so I tried a bigger part. This part is 340mm long. The first two layers were perfect. I watched them go down. Then I went away for a few hours and came back to this. Can anybody clue me in what's going on here?

    You can see where the compensation messed up. This is supposed to be a .1mm layer print. The left side is about right. The left is just crazy.

  • If anybody is curious to what happened here. I seem to have the problem beat. I took a level to the table the printer is sitting on and noticed that the top has warped under the weight of the printer. Two corners were on supports under the table, but the third was in the middle of the table. The middle of the table had sagged down almost 10mm under the printers weight. I guess when I took off the bed things shifted out of correctable zone and printer went haywire.
Sign In or Register to comment.