Help! Extruder prints off center after a few layers

Hi all, I'm very new to the world of 3D printing as I just recently purchased my very first 3D printer, the Zonestar M8R2. It's a DIY mixed color printer with 1 nozzle and a heated bed running Repetier Firmware 0.92.9. The dimensions are x =220, y =220, z =240. Mechanically everything works perfectly fine and as a test I managed to even print a small block using Repetier Host V2.0.5 and CuraEngine as a slicer. Not being familiar with G-code I tried out some settings to get the Z-axes closer to the bed. After that it seems that with every object I try to print the first couple of layers are properly centered as it should but soon after the z-axes goes off center and starts printing in a totally different directions.
I've tried to find the solution by changing a few of the settings; 1 extruder instead of 2, relative instead of absolute positioning. As z homes about 10 mm from the bed, I tried x Min =10, y min =10, Bed Left = -10, Bed Front = -10, but nothing seems to solve my problem.
I've done a search online but was not able to find anyone who experienced the same problems as I do, so I hope that maybe some of you might now the solution to this. Below my printer settings in RH and firmware EEPROM config and a some pics to give you an idea.
Many thanks in advance!


  • Looks like the firmware detects a endstop signal and prevents moves sometimes. Can happen with crosstalk to endstops. First solution is to disable endstop check in firmware. Compile with
    set in configuration. That way false signals have no influence during print, only during homing. If that helps you could twist endstop and motor cables to reduce crosstalk.

    Other reason is motor lossing steps, but the differences are quite big for that, so my bet is endstop.
  • Thanks for your quick reply! I've requested Zonestar the Firmware source code so I can carry out your advice. Will let you know the outcome. Cheers!
  • Why not take the opportunity to update the firmware to the latest 1.0

  • MartinH said:
    Why not take the opportunity to update the firmware to the latest 1.0

    Thanks for the suggestion! Started compiling fw 1.0 Repetier.ino now.
  • Hi guys, all problems solved. Measured the voltage going through the driver modules and adjusted the potentiometers. All running smoothly now. Unfortunately Repetier fw 1.0 wasn't working for me so back to the initial version. Thanks for your help!
Sign In or Register to comment.