eeprom ?

If I run repetier host and I have eeprom turned on the firmware eeprom configuration is not highlighted

if I set the eeprom to off in the config then the firmware eeprom configuration is highlighted but when I use it doesn't show any eeprom settings

I am trying to change the eeprom baudrate it shows with m205 113550 and I can't seem to change it, the config is set at 250000

every time I try an m206 it echos extruder and flowrate 100

any suggestions?

Thanks gary


  • After each M206 values get copied to ram which causes it to output some vars like flowrate.

    There was an 1.0 version where eeprom capability reporting was wrong so that host disabled it when enabled. Sounds like you need to update your 1.0 to fix this.
  • Thanks got it working now..
  • Have another question I have E0 setup for the extruder motor, I can't get the motor to move, tested the motor on X axis and it worked put in a new driver and it locks the motor on e0, but can't get it to go anywhere checked the eeprom setting and don't see ext.0 only ext.1 is this correct I don't see a way to clean or overwrite this. I then disabled the eeprom

    to load from the config that has only e0 enabled but still no motor movement..

    Thanks gary

  • In eeprom we start with Extr. 1 since hsots start also numbering with 1, also internally this is still E0. Make sure you have set steps per mm in eeprom and the extruder is hot. Use M302 S1 to allow extrusion while motor is cold.
  • Dont forget, unless cold extrusion is enabled(M302 S1), the extruder motor will not move unless the nozzle is heated to about 150 degC
  • it did heat up but when the print started I got the message on the lcd screen def/ bedheater or something close to that.

    then both heaters shut down but the printer keep running till the end,

     the hot end and bed are new first time heating up.

    I will test m301 s1 to make rule that out 

    thanks gary

  • tried the m302 s1 said cold fusion enabled but still no movement would it make sense to attach my config file or at least the heated parts..


  • Normally not. We do not know your hardware to see errors in config.

    Big question is blocks motor when enabling printer or only if you start extruding? In first case your enable signal is wrong.

    It could be an error on the board. Since most boards have 2 extruder sockets you could put it in socket for E1 and in config tool switch motor socket to E1 and try again. And if drivers can be removed you can use x driver for it a syou tested this to work already eliminating error sources.

    Try with no filament inserted! Otherwise it might block the motor, so start only with filament once you know motor is working.
  • Also check in eeprom editor what your E0 steps/mm are set too.
  • I went and added a driver to E1 and reconfigured the software I can now move the extruder motor so I assume there is a problem with the ramps or Arduino at least as far as for E0 output..

    Thanks gary

Sign In or Register to comment.